Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. chudiddy

    Joined:
    Sep 14, 2014
    Messages:
    4
    Likes Received:
    0
    I need help. I flew my P4 perfectly yesterday. I'm on the very latest firmware and DJI GO app. I tried to fly today but as soon as the bird reaches about 20 feet it disconnects and auto lands. I tried several times and just keeps doing the same thing. I am at a loss and frustrated. How can it fly perfectly fine yesterday and now all of a sudden it won't fly. GPS signals are fine with 12+ satellites. Home point is located and "safe to fly" comes up. Just won't fly above 20 feet without disconnecting from RC and bird lands itself. Can anyone help me out?

    Mike
     
  2. henick

    Joined:
    Jan 2, 2016
    Messages:
    302
    Likes Received:
    61
    Post a log to be sure. There is a HD (healthy drones) app for iOS and Android that does it automatically. Could be any number of things. RTH lands if pressed within so many feet of rc... anything said would be a guess without a log or some type of context.
     
  3. Ibmftw

    Joined:
    Apr 1, 2016
    Messages:
    203
    Likes Received:
    82
    @chudiddy you haven't accidently set beginner mode or max flight distance within the GO app, have you?
     
  4. chudiddy

    Joined:
    Sep 14, 2014
    Messages:
    4
    Likes Received:
    0
    Not sure how to grab flight logs.

    Not in beginner mode. Checked that numerous times. Is there a way to do a hard reset on both the controller and the P4?
     
  5. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,753
    Likes Received:
    3,465
    Try this:
    Go to http://www.phantomhelp.com/LogViewer/Upload/
    Follow the instructions to upload your flight record.

    Come back and post a link to the report it provides
     
  6. chudiddy

    Joined:
    Sep 14, 2014
    Messages:
    4
    Likes Received:
    0
    HealthyDrones.com - Innovative flight data analysis that matters

    Ok here is my log. Hopefully someone can figure out what is going on. I thought it might have been the DJI GO APP so i downgraded last night to 2.8.1 and that didn't resolve the problem.

    Just goes up in the air about 20 feet then displays "weak transmission signal", then lands itself. Really frustrating. Don't know what to do. Thanks in advance
     
  7. Ibmftw

    Joined:
    Apr 1, 2016
    Messages:
    203
    Likes Received:
    82
    @chudiddy Try deleting the app and any other apps you have that you use to fly the phantom, try calibrating everything you can, and then re link the RC.
     
  8. konidair

    Joined:
    Mar 6, 2016
    Messages:
    127
    Likes Received:
    36
    Location:
    Sydney, Australia
    Interference maybe? Have you tried flying in a different location?

    "A 00m 00s 0.0 ft 0 ft Mode Mode changed to GPS_Atti
    B 00m 02s 0.0 ft 1 ft Mode Mode changed to AutoTakeoff
    C 00m 02s 0.0 ft 1 ft Tip Tips__Taking Off
    D 00m 05s 3.0 ft 3 ft Mode Mode changed to GPS_Atti
    E 00m 41s 6.6 ft 4 ft Data Loss Downlink data connection lost for 8.9 seconds
    F 00m 41s 6.6 ft 4 ft Mode Mode changed to WiFi_Reconnect
    G 00m 41s 6.2 ft 4 ft Mode Mode changed to AutoLanding



    Explanation

    Downlink data connection lost ( Data Loss ) means that the remote got partial or no flight data from the aircraft for more than 1 second, which means the data downlink had issues.

    It is possible that during this time there is a sense of full control of the aircraft via the remote as well as clear video, however typically the video gets choppy and the remote controls may have some delay.

    This is typically an indication that the aircraft was flying in a high interference area or that distance was a negative factor. In these conditions the aircraft is at higher risk of initiating the Return-To-Home function."
     
  9. chudiddy

    Joined:
    Sep 14, 2014
    Messages:
    4
    Likes Received:
    0
    I've tried everything from deleting and reinstalling the app, refreshing the firmware on the bird (which fails 100% of the time), downgrading the DJI GO app, different battery, tried an ipad, etc. Still lands itself once it reaches 20 ft. The thing that boggles my mind is that it flew absolutely perfect just less than 24 hours earlier. Could a few drops of water on the P4 cause this behavior?

    I bought this p4 over a month ago brand new on eBay, can i theoretically send it in to DJI and have it covered under warranty. I don't have a receipt except for proof of purchase from ebay.