Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Need help iosd won't update

Discussion in 'Phantom 2 Discussion' started by rcimpulse, Mar 27, 2014.

  1. rcimpulse

    Joined:
    Mar 26, 2014
    Messages:
    20
    Likes Received:
    0
    So I got to setting up and trying the ground-station without the IOSD mini connected and no fpv this time about.
    Anyway I have been trying to update the iosd mini through the PC software but it glows a solid red. Anyone have the same problem and shed some light on this issue. I double checked all the wiring. No luck
     
  2. hook3m

    Joined:
    Jan 19, 2014
    Messages:
    95
    Likes Received:
    0
    Location:
    Austin Texas
    Just a thought. Make sure you are using the DJI iOSD Assistant software and not the DJI Phantom Assistant and you are plugged directly into the iOSD. That is the only thing that comes to mind.
     
  3. rcimpulse

    Joined:
    Mar 26, 2014
    Messages:
    20
    Likes Received:
    0
    Yes I'm using the iosd assistant software 4.0 still really heats up,and won't detect on my PC. Someone please help me setup my last piece of intelligence . Solid red and gets really hot after about 3-4 minutes.
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Do you have the iOSD connected to the canbus port and the Phantom powered on when you're trying this?
     
  5. rcimpulse

    Joined:
    Mar 26, 2014
    Messages:
    20
    Likes Received:
    0
    Checked all wires connected USB to iosd video in out connected correctly and canbus also connected. :( been trying I stalking the driver again. Btw mine shows iosd not iosd mini is iosd software. :?:
     
  6. rcimpulse

    Joined:
    Mar 26, 2014
    Messages:
    20
    Likes Received:
    0
    No one got an IOSD mini solid red no update possible? :twisted:
     
  7. goldfishrock

    Joined:
    Jan 7, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Devon, UK
    Sounds like a driver issue to me. First thing is to confirm the DJI Driver is installed properly. If you plug your P2 into the normal Assistant software can you see everything ok, calibrate etc? Once you've confirmed this, turn the phantom off, disconnect the USB. If this fails, download the correct driver (DJI WIN Driver Installer) from here

    http://www.dji.com/product/phantom-2/download

    Now, make sure you've got the correct software for the IOSD. Download the 'iOSD Assistant Software v4.0' from here

    http://www.dji.com/product/iosd-mark-ii/download

    Install it but DON'T run it yet! Now plug into the IOSD Mini & power the P2 back up. Now run the IOSD Assistant Software once the P2 is powered up.

    I found sometimes that the P2 & the IOSD aren't recognised if the sofware is already running before connecting. The sure fire way to make sure you get a connection to to close it all down and only run it once the P2 is connected and powerd up.

    Give it a go and let us know how you get on. The red light isn't good, it means there is a problem communicating. If the driver reinstall / update doesn't work, try a different USB cable with a micro USB connector. If both of those fail I would say your IOSD is DOA :-(
     
  8. rcimpulse

    Joined:
    Mar 26, 2014
    Messages:
    20
    Likes Received:
    0
    Right so I did all of the above. Is it possible I may have connected the video in and out reverse ? May have caused a short ? No idea? I do get a red light and it gets really hot. This has been an issue before all the updates. Should I get in touch with DJI?