Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Naza Lite in a HK Quanum Venture

Discussion in 'Phantom 1 Help' started by radioguy, Dec 13, 2014.

  1. radioguy

    Joined:
    May 18, 2013
    Messages:
    112
    Likes Received:
    14
    Location:
    Oklahoma City, Oklahoma
    I bought this quad from Hobby King. It's got a Naza Lite with GPS. I'm using a re purposed Phantom 1 radio and receiver (the same combo I'm using with my F550 with excellent results).

    I was able to bind the new receiver to the transmitter without any problems. I downloaded the Naza Lite Assistant software and connected to the Naza Lite easily.

    The problem I'm having is when I check the function of the right hand 3 position switch. It will give me GPS and allow me to switch to ATTI, just like it's supposed to. However, when I go to position 3, it lands up on manual mode. I can see there's a dropdown box which should allow me to choose Failsafe instead of manual, but when I click on it, I can't get it to change and give me that option. Any ideas?

    Thanks!

    Fred in OKC
     
  2. radioguy

    Joined:
    May 18, 2013
    Messages:
    112
    Likes Received:
    14
    Location:
    Oklahoma City, Oklahoma
    Found and fixed the problem. I upgraded the Naza Lite to Naza M and the problem went away. I now have all 3 modes on my DJI radio-GPS, ATTI and FAILSAFE. All switch selectable. Now to get it in the air and see if things have improved.