Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Mystery of the lights in the sky.

Discussion in 'General Discussion' started by Zippy1144, Mar 13, 2014.

  1. Zippy1144

    Feb 21, 2014
    Likes Received:
    Could be a Hardy Boys title, but I have a bit of a head scratcher.
    1. Although we had, according to the DJI App, 10 satellites linked, and the icon was green on the app screen. However, the lights on the rear(battery side) were flashing red & green rapidly. The battery was showing 95%. We decided to launch. The Vision flew perfectly in a rather stiff breeze.
    2. We continued to fly close to base to see if all was performing normally. It hovered and held position perfectly.
    3. When we rotated the Phantom 2 it would move horizontally because of the wind...then it would return to its hover position.
    4. We flew the craft 40 m away and shut off the controller. It returned home perfectly.
    5. All this time the lights continued to flash rapidly. But the app readout showed all as "normal".
    6. Actually the Phantom flew better than usual...I did less circling and stayed more steady in the wind.

    Sep 5, 2013
    Likes Received:
    N 44.895 W 93.354 Minnesota
    I'm not sure on P2s but on P1s when on course lock or home lock mode you'll get a red flash between the green. (Of course when less than 6 sats but you mentioned you had 10)
  3. Pull_Up

    Nov 5, 2013
    Likes Received:
    South Oxfordshire, UK
    I'm guessing you're running your Vision as stock, so you won't have any IOC modes available...

    A rapid red/green isn't a standard Vision led code. Rapid Red/Yellow means you need to do a compass calibration, but that would also be accompanied by a warning on the phone screen.

    If you have changed it to Naza mode then it could be that you actually had 6 or fewer sats locked. Have a look at this video, did any of the flashes look like the ones in there? http://www.youtube.com/watch?v=2BeakjoJ1UA