Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

my phantom is flying bad since gimbal installation

Discussion in 'Phantom FC40 Discussion' started by jozee, Mar 19, 2014.

  1. jozee

    Joined:
    Mar 19, 2014
    Messages:
    2
    Likes Received:
    0
    Hi,
    I've installed this gimbal:
    http://www.ebay.com/itm/RTF-Gopro-H...Control_Parts_Accessories&hash=item3cde3cef4f

    since then my phantom is not aligned.
    1. liftoff is weird, it goes nose down all the way and then goes up.
    2. when its on the air its always tilted to the right.
    3. it doesn't maintain position and height, its hovering all over.
    4. when i fly forward it doesn't maintain height and it going down slowly .

    * gps is ok, all green.
    * i did advanced calibration through naza software
    * i did a campus calibration.

    Any ideas what else should i do?

    Thanks
     
  2. RUSHNREADY DJI

    Joined:
    Mar 11, 2014
    Messages:
    175
    Likes Received:
    0
    You want to have play with gain

    to stop it tilting to the side you want to change the roll if your looking at the front when its in the air and its tilted right lower the basic gain roll by 10. I had to do this and it worked. now sounds like you need to calibrate your controller i would do this first make sure its all fine do you know how to do this? once thats done then see if your experience the same problem when flying forward and taking off. if so adjust your vertical basic gain.up by ten and see how that helps. When you have conected you phantom to pc with the assistant software it will say what each one does any way. hope this helps let me know how you get on and good luck
     
  3. jozee

    Joined:
    Mar 19, 2014
    Messages:
    2
    Likes Received:
    0
    Hi,
    I forgot to say that i calibrated the remote already.

    I will try to play with gain.

    How can i fix the nose down while take off?
     
  4. RUSHNREADY DJI

    Joined:
    Mar 11, 2014
    Messages:
    175
    Likes Received:
    0
    maybe the front propelers not going fast enough has it been like this since you got it ? if so call the supplier if not have a play with the gain have a look at a chart that explains yaw roll and so on you will be able to see what you will need to adjust form the picture