Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional My P3P don't hold anymore a position in flight

Discussion in 'Phantom 3 Help' started by Gracy, Apr 20, 2016.

  1. Gracy

    Joined:
    Jan 17, 2016
    Messages:
    15
    Likes Received:
    2
    Hello,

    I have a P3P from about 4 months, and all worked fine till now, I don't know if the reason is the new firmware update or a little crash I had 2-3 weeks ago.

    My P3P fly fine in P mode, but as soon I switch to the F mode, the aircraft stop to hoover and it begins to go left (same if I press left on the right stick of the RC), it stops to go left and hoover again if I'll switch back to P mode.
    I though to be a IMU problem, but the check on it via DJI GO App tells there is no need of an IMU Calibration.

    What should I do to fix this bug?

    Thanks in advance

    Roberto Gracy

    PS. My system is:

    P3S new engine
    DJI GO App IOS version 2.7.2
    Aircraft Firmware version 1.8.80
    RC Firmware version 1.6.0
     
    #1 Gracy, Apr 20, 2016
    Last edited: Apr 20, 2016
  2. Numone

    Joined:
    Jan 10, 2016
    Messages:
    885
    Likes Received:
    239
    Location:
    Surrey, England
    Ignore what the app says and calibrate the IMU and compass to at least check if that fixes the issue....
     
    Gracy likes this.
  3. Gracy

    Joined:
    Jan 17, 2016
    Messages:
    15
    Likes Received:
    2
    Thanks,
    I just completed the IMU calibration, in a flat surface, with a temperature of about 19 C°, it has completed successfully (message says "Calibrated" at the end of the process) ...
    but still the problem persists: when I am in P mode all is fine, the aircraft hold the position in flight, as soon I try to use the F mode, it start to drift

    Thanks again
     
  4. Numone

    Joined:
    Jan 10, 2016
    Messages:
    885
    Likes Received:
    239
    Location:
    Surrey, England
    Hmmm. Don't understand that, as I thought all the systems used under "P" mode are used under "F" mode too. I'm sure someone will be along with further ideas / suggestions shortly....
     
    Gracy likes this.
  5. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    492
    Likes Received:
    117
    Location:
    Mountain City, TN
    Any chance that when you flip the switch to go into F mode, that it is only going into ATTI mode?

    Sent from my SM-N910V using Tapatalk
     
    Gracy likes this.
  6. Gracy

    Joined:
    Jan 17, 2016
    Messages:
    15
    Likes Received:
    2
    Thanks, I did another IMU calibration and now it's fine.
     
  7. Numone

    Joined:
    Jan 10, 2016
    Messages:
    885
    Likes Received:
    239
    Location:
    Surrey, England
    Excellent news!:D
     
    Gracy likes this.
  8. Gracy

    Joined:
    Jan 17, 2016
    Messages:
    15
    Likes Received:
    2
    I just add that, having readed that is better have the aircraft cold before start again the IMU calibration, I've left all night the Phantom on the outdoor balcony at about 10°C