Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

My motors won't start

Discussion in 'Phantom 2 Discussion' started by Bluegrass, Jun 17, 2014.

  1. Bluegrass

    Apr 8, 2014
    Likes Received:
    Somewhere along the way in troubleshooting my new Z3D problems and redoing all the latest updates my motors won't start. I have followed pointers on this forum and Google and have been trying for 2 days now to get the advance IMU calibration to work correctly. The mod numbers are in the under 1000 range. Mostly around 350.

    I've tried waving a magnet around the magnetic compass more then a dozen times but I still can't get the number in the 1400 to 1800 range that I read it was suppose to be in. I did fly the Phantom after installing the new Z3D (broke my Z2D in a crash) but it had some yay & pitch twitching that I was trying to fix when the motors quit working. Also I swear I thought my RC power light use to be red and now it's yellow. I can get through the GPS calibration after powering on OK.

    If anyone has any suggestion for me to try, I would greatly appreciate it.
  2. FedeVision

    Mar 13, 2014
    Likes Received:
    San Jose, Costa Rica
    If I'm not wrong, yellow light on RC means you need to rebind RC and Phantom,
    check the manual, hope this helps. GL
  3. britchris1

    Mar 19, 2014
    Likes Received:
    Manchester, NH
    I had the same problem after an update I did. First I re-calibrated the RC using the RC assistant software, then I calibrated again in the P2 assistant software. Once that was done everything seemed to go back to normal. Hope it works for you. If not theres a way to rebind the transmitter - turn the P2 over you will see what looks like a screw hole but if you look close its actually an led/button thats recessed.

    1.Power off the remote controller, power on the aircraft. You will see the link indicator blinking red.

    2.Press the linkbutton with a thin object and hold until the link indicator blinks yellow.Release the link button.

    3.Power on the remote controller and the link indicator should switch off. This indicates that the link has been successfully established.