Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

My flight controls are backward!!! ANYONE?!!!!

Discussion in 'General Discussion' started by josephza, Dec 9, 2014.

  1. josephza

    Joined:
    Nov 14, 2014
    Messages:
    6
    Likes Received:
    0
    Ive replaced, Main controller/mother board/LED. It all started when I plugged my gimbal in backward and it fried the main controller. HELP!!!!!!!!
     
  2. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    Have you checked in the assistant program that the controls haven't been reversed? You can set them normal or reversed. Something wired incorrectly?
     
  3. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Perhaps if you plugged the motor signal connector upside down, you might have this issue; though I'd think that would cause other problems.
    Definitely check the settings with the Phantom Assistant SW.
     
  4. josephza

    Joined:
    Nov 14, 2014
    Messages:
    6
    Likes Received:
    0
    It was the settings, thank you! Ok, What do you recommend for the voltage settings? I think mine are screwy. it descends on its own right away.
     
  5. josephza

    Joined:
    Nov 14, 2014
    Messages:
    6
    Likes Received:
    0
    I just found your reply from Oct to this issue....you were right about the settings. Now I would appreciate some advice on the Voltage settings for first and second warning.