Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

My first crash today need ***.

Discussion in 'Phantom 1 Help' started by mfbs17, Oct 13, 2013.

  1. mfbs17

    Joined:
    Sep 21, 2013
    Messages:
    21
    Likes Received:
    0
    Hi all
    I had unusual crash today which I cant figure it out why and need some suggestion to look into so
    that I wont make the same mistake,if it was any.I still newbi and fly for the time being in gps mode to learn the phantom.

    I turned on the Tx and power up the phantom with full charge battery and during the half way of the wam up 4x yellow lights
    it Begins to bip-- bip--bip sound and I disconnect and after 2 min reconnected the battery and went through the warm up and the rest of light sequences and I was in gps mode and after 2 min of flying all of the suddan with almost about 50 meter away flipped several times and I tried to control it but no respond and crashed luckly on high grass area.Any suggestion would be very helpfull.

    Thanks
    Mo :)
     
  2. netphreak

    Joined:
    Sep 17, 2013
    Messages:
    228
    Likes Received:
    0
    Have you plugged into your computer and checked your mod values? It sounds like you might have a stuck sensor inside your NAZA.
     
  3. mfbs17

    Joined:
    Sep 21, 2013
    Messages:
    21
    Likes Received:
    0
    I had a coupel of flight Day before and a single flight before the crash.any cause for sensor stuck in naza?what is The solution?
    Thanks

    Sendt fra min HTC One med Tapatalk now Free
     
  4. Imabiggles

    Joined:
    Oct 11, 2013
    Messages:
    299
    Likes Received:
    84
    "My first crash today need ***" - *** may comfort you, but it offers no help for the phantom
     
  5. mfbs17

    Joined:
    Sep 21, 2013
    Messages:
    21
    Likes Received:
    0
    True

    Sendt fra min HTC One med Tapatalk
     
  6. Fdnyfish

    Joined:
    Jun 6, 2013
    Messages:
    664
    Likes Received:
    36
    Location:
    Barnesville, PA
    How do you un-stick a sensor in naza
     
  7. miskatonic

    Joined:
    Sep 11, 2013
    Messages:
    351
    Likes Received:
    0
    Sounds like you may have needed to do a re-calibration of the IMU and then the compass.