Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Motors won't turn on, get fast blinking green LEDs w/ CSC

Discussion in 'Phantom 2 Discussion' started by adster, May 29, 2014.

  1. adster

    Joined:
    Apr 16, 2014
    Messages:
    20
    Likes Received:
    0
    So I finally got everything updated and calibrated on my P2. I disconnect it and test out the the startup in my living room. I move the throttle to the CSC position and everything starts up in my living room. Booya.

    I head outside and wait for the all-green blinking lights showing I have satellite lock. I try to turn on the motors but they won't turn on. Each time I try using the CSC throttle command, I get a series of very fast blinking green lights.

    Is it something to do with the GPS? I'm not in a no fly zone (but theres one about 8 miles away) however you can at least startup the motors in a no-fly zone, right?
     
  2. Sanababit

    Joined:
    Apr 20, 2014
    Messages:
    125
    Likes Received:
    0
    Re: Motors won't turn on, get fast blinking green LEDs w/ CS

    Did you calibrate the remote control too?

    Sana
     
  3. ginsonic

    Joined:
    Nov 8, 2013
    Messages:
    103
    Likes Received:
    0
    Re: Motors won't turn on, get fast blinking green LEDs w/ CS

    Need calibrate remote control. This happen to me too and fixed after calibration.
     
  4. adster

    Joined:
    Apr 16, 2014
    Messages:
    20
    Likes Received:
    0
    Re: Motors won't turn on, get fast blinking green LEDs w/ CS

    Yep, remote is calibrated. I'll run the calibration and then turn on the motors inside and they work just fine. But if I turn off the copter, take it outside and try again I get the flashing green lights. I shouldn't have to calibrate the remote each time I turn on the Phantom?