Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

motors wont start - phantom 1

Discussion in 'Phantom 1 Help' started by El Jefe, Feb 6, 2016.

  1. El Jefe

    Feb 6, 2016
    Likes Received:
    I have flown my Phantom 1 on 6 flights or so without a single issue. Today I took it out and the motors would not start up. The lighting sequence was all good to go, but nothing happened when I tried to initiate the motors. Any thoughts??
  2. gianni_BT

    Jun 24, 2015
    Likes Received:
    Lighting sequence means that you got the flashing green light(no yellow or red/yellow indication)?
    In this case it is really strange. It seems a binding problem between the transmitter and the quad.
    It can also be a loss of calibration of the transmitter sticks, so, first of all, I would suggest to try all the possibilities of the CSC sequence (both sticks at bottom right, both at bottom left, the left stick at bottom left and the right at bottom right, the left stick at bottom right and the right at bottom left). I would try these sequences in all the 3 possible positions of the GPS/ATTI/MANUAL selector.
    After that I would try the IMU calibration dance, just to verify that when you switch the right switch from GPS to ATTI and back several times, the calibration sequence is initiated: this is another indication that the communication remote/quad is OK.
    At this point you should continue connecting with the Naza assistant, to verify the stick calibration or check if you have any other suggestion from the assistant about need of calibrations.
    Another point: sure that the transmitter batteries are charged(no red or BIP indications on the transmitter)? Sorry for the stupid question, but sometimes the obvious reasons are not taken in consideration.