Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Motors no power

Discussion in 'Phantom 2 Help' started by benewt, Aug 26, 2014.

  1. benewt

    Joined:
    Apr 14, 2014
    Messages:
    2
    Likes Received:
    0
    OK...so I did the stupid maneuver of putting the long prop guard screws back into my Phantom 2 and buggered the motors. Initially 3 of them shuttered, telling me about the damage. I purchased 4 new motors. I tried to power up the old ones to find the 3 that were broken and nothing happened. Like the unit didnt receive the signal to power on the motors. All calibrations are good on the remote and the drone and all signals are receiving. So..a few questions
    I have the Phantom 2 with HD-3D gimbal
    1) Does anyone know if there is a way to test if the ESC are bad?
    2) should I replace the motors and test them again?
    3) could there be another problem outside of the ESC and motors?

    I live in the middle of no where and truly hard to send to a tech. Does anyone know of someone I can call to help me through this?
     
  2. Phantom Phixer

    Joined:
    Jul 13, 2014
    Messages:
    27
    Likes Received:
    0
    Make sure that the craft is paired to your transmitter before doing anything. Try again. If this doesn't work you can call DSLRPros support team they would be happy to help!
     
  3. benewt

    Joined:
    Apr 14, 2014
    Messages:
    2
    Likes Received:
    0
    The unit is communicating fine with the RC. Everything is working except the power up portion for the motors.

    again...
    Now I have, purchased 4 new motors and installed them. Before I installed the new motors I tried to power up the old ones to find the 3 that were broken and nothing happened. Like the unit didnt receive the signal to power on the motors. All calibrations are good on the remote and the drone and all signals are receiving. Now that I have installed the motors the same thing is happening.
    So..a few questions.
    I have the Phantom 2 with HD-3D gimbal
    1) Does anyone know if there is a way to test if the ESCs are bad?
    2) is there something else that cold e stopping the motors from spinning up?

    Any advise is greatly appreciated as I live on a small island in the middle of no where and cant take the drone to a tech.