Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Motors do not start

Discussion in 'Phantom FC40 Discussion' started by elmllc, Apr 24, 2014.

  1. elmllc

    Joined:
    Apr 24, 2014
    Messages:
    4
    Likes Received:
    0
    Please help, I cannot get the motors to start on my NEW FC40. They have only started three times at random in SEVERAL tries, have not even been able to start flying. Any ideas...
     
  2. KennyBKK

    Joined:
    Apr 14, 2014
    Messages:
    12
    Likes Received:
    0
    What is your status light at the Phantom?

    Kanok


    Sent from my iPad using Tapatalk HD
     
  3. elmllc

    Joined:
    Apr 24, 2014
    Messages:
    4
    Likes Received:
    0
    In GPS mode and a single green blinking light. When I activate controls to start motors, get a double blink green light, sometimes will go back to one when sticks released, sometimes wont (which I know means that the sticks are centered).
     
  4. T0Rtur3

    Joined:
    Apr 6, 2014
    Messages:
    79
    Likes Received:
    0
    Are you holding the sticks inward diagonally? Don't just push them in and let them go, make sure you hold them until the motors start.
     
  5. elmllc

    Joined:
    Apr 24, 2014
    Messages:
    4
    Likes Received:
    0
    I have held them in all four of the positions that are recommended in the manual for 15-20 seconds, nothing happens...
     
  6. elmllc

    Joined:
    Apr 24, 2014
    Messages:
    4
    Likes Received:
    0
    Hoooray! I figured it out, finally. I connected to the computer and checked my calibration and found that one channel (A) did not have full range of motion so it was not travelling far enough to engage. After re-calibration everything works EXCELLENT!! I know, I'm a newbie and should have done this before asking the question. Hopefully someone else can learn from my mistake.
     
  7. T0Rtur3

    Joined:
    Apr 6, 2014
    Messages:
    79
    Likes Received:
    0
    Nice! Glad you got it worked out, and thank you for posting the solution. I'm sure it will help out others as well.