Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Motor Binding

Discussion in 'Phantom 2 Discussion' started by frank3.0, Feb 28, 2014.

  1. frank3.0

    Joined:
    Feb 1, 2014
    Messages:
    5
    Likes Received:
    0
    I think this is from the overlong screws that come with the prop guards but my motors are no longer spinning properly. I don't think it is the ESCs as I get four chimes when I start it up.

    Also, the new gimble IMU upgrade won't load. Any issues similar to this out there?
     
  2. nintendrone64

    Joined:
    Feb 19, 2014
    Messages:
    353
    Likes Received:
    2
    Location:
    Simi Valley, CA
    Definitely going to need some new motors ):
    But I think you should contact DJI, because that is total BS!

    Also, what happens when you try to upgrade?
     
  3. Jaybee

    Joined:
    Dec 24, 2013
    Messages:
    372
    Likes Received:
    17
    Location:
    Bristol UK
    I had this issue with a brand new P2 and H3-2D. If your IMU software says 0.0, won;t update, and has a garbled hardware ID, send it back. I got a replacement shipped out and it all works as expected.
     
  4. frank3.0

    Joined:
    Feb 1, 2014
    Messages:
    5
    Likes Received:
    0
    Thanks for the info, folks!
     
Loading...
Similar Threads - Motor Binding Forum Date
Motor overload Pro/Adv Discussion Yesterday at 8:52 AM
HOW HOT SHOULD MOTORS GET ? General Discussion Sunday at 10:24 PM
Prop Motors Overheating? Pro/Adv Discussion Sunday at 7:52 PM
Professional Phantom 3 Motor not working Phantom 3 Help Sunday at 4:06 PM
Gimbal Motor overloaded? Phantom 4 Pro Help Saturday at 9:05 AM