Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

More Litchi help

Discussion in 'Pro/Adv Discussion' started by NEWBeeWithPhantom, Dec 28, 2015.

  1. NEWBeeWithPhantom

    Joined:
    Dec 28, 2015
    Messages:
    24
    Likes Received:
    1
    I just downloaded the Litchi App on my tablet and upon starting it up, it says "checking permissions", then gives an App Error "cannot connect to internet to verify app". This is odd since I just downloaded it and installed it on my internet connection. The internet is good. What do I need to do? I removed DJIGO just to make sure that it was not interfering with this app. What else needs to be connected? This tablet is running Android 5.1.1.
     
  2. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    Have you got the bird connected? Give it another go in the house, props off, wifi on the tablet on and you should be good. Once done, you won't need to do it again.
     
  3. Wingman624

    Joined:
    Dec 26, 2015
    Messages:
    18
    Likes Received:
    6
    Had the same thing happen to me. First, turn off the decoding in the DJI app and then delete and reinstall the Litchi app. Everything should then work.
     
  4. GunnyPapa

    Joined:
    Nov 28, 2015
    Messages:
    201
    Likes Received:
    39
    Downloaded same a few hours ago no issues. I would reboot tablet. There are issues in android tabs that shut WiFi /Internet off for a sec that dies this when both apps are requesting permission to access. Reboot, check the Litchi app in your tab in settings to make sure it was installed. Turn on tab, phantom, turn on controller. Tab should as you what app you want to use, DJIGO or LITCHI.
    Let me know if this works for you brother.
     
  5. NEWBeeWithPhantom

    Joined:
    Dec 28, 2015
    Messages:
    24
    Likes Received:
    1
    Thanks for the response of you three. I tried it all. Nothing works. I now believe that Litchi is not compatible with my tablet. I am also having problems wit DJIGO in that it will not show the camera image, although it does show the drone's condition and the RC will control the drone but without a picture. My Samsung Note 5 does it all, although the screen is too small for me, but alas, I will probably have to go to a different tablet and make sure that tablet is on the list of tablets that do work. It is probably the way that the USB port is configured on the tablet, but re-configuring a USB port is beyond me.
     
  6. GunnyPapa

    Joined:
    Nov 28, 2015
    Messages:
    201
    Likes Received:
    39
    I have Samsung TAb4, Litchi kept crashing when I ever I switched camera modes. Got good help from Litchi Support, but they can not figure it out at this time. They refunded me, no questions asked. DJIGO works 110% on my tab, so until Litchi figures it out I am staying with what I know works and reliable.
     
  7. KC4E

    Joined:
    Jan 26, 2016
    Messages:
    40
    Likes Received:
    1
    Location:
    Tucson AZ,
    I have a p3a and I think I know what is happening. not why but what. I have two identical phones. it was buy one get one free. htc one m8. one has vzw service and the other is just a spare. no service just Wi-Fi. I have been using djigo app. and it works great on my spare phone even when I go hiking and there is no Wi-Fi. I just recently downloaded litchi and I got "cannot connect to dji servers to verify the app" with a good Wi-Fi connection at my house. I tried my everyday phone with Wi-Fi and got the same message. then I tried my everyday phone with Wi-Fi off and 4g on and it worked great. then I went back to Wi-Fi on my everyday phone and it worked. yay I got it but wait. if you restart the phone it has to do it all over again. litchi doesn't need internet it needs cell data service (4G). this sucks because I wanted to use my spare phone in my drone backpack in the off and charge state so I can just grab it and go. I like litchi because I use the VR view and it is awesome. it controls the camera with head movements and i can fly very close to cliffs canyons and trees.
     
  8. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,519
    Likes Received:
    1,387
    Location:
    Salt Lake City, UT
    Help - Litchi

    1. Why is Litchi not connecting to my Phantom 3/Inspire 1?
    When starting the app for the first time, you will need to be connected to Internet in order to validate the app with DJI servers.
    Be aware that some Internet connections may have troubles connecting to DJI servers, in such a case make sure to try a different Internet connection (home wifi, mobile data connection, a friend's connection, public wifi, etc).
    Additionally, on Android if DJI Go is your default app for the remote controller USB connection, you will need to clear the defaults for DJI Go (Settings -> Apps -> DJI Go -> Clear Defaults).
    Make sure you are using the latest DJI firmwares on both your RC and aircraft.
    Then, follow these steps:

    • If needed, restart your mobile device to make sure no apps are running in the background including Litchi itself.
    • Start your aircraft and remote controller, and let them initialize for a few seconds (do not start Litchi just yet).
    • If you have a P3 Standard/P3 4K, connect to the wifi network of the aircraft, otherwise plug the remote controller into the mobile device.
    • If you have a P3 Standard/P3 4K or if you are on iOS: start Litchi directly. In all other cases, select Litchi in the popup to initiate connection.
    • If you are on iOS and don't see video, try disabling Hardware Decoding in the settings.
     
  9. KC4E

    Joined:
    Jan 26, 2016
    Messages:
    40
    Likes Received:
    1
    Location:
    Tucson AZ,
    tcope if I restart my phone does litchi need to use my friends internet again to connect to DJI servers. also does litchi know why some internet and not others work with DJI servers. I would like to make litchi my only app but I need to get this DJI server thing figured out. thanks for any input.
    ps. I deleted DJI app on both of my phones and did a factory reset. same problem.
     
  10. PrecisionAeroworks

    Joined:
    Feb 21, 2016
    Messages:
    261
    Likes Received:
    106
    Location:
    Colorado, USA
    No. Verification is a one-time thing per device (unless and until you reinstall the app on that device). At least that is how it is supposed to work. And how it has worked for me on my Galaxy S5 and my WiFi only Galaxy Tab S 10.5.
     
  11. KC4E

    Joined:
    Jan 26, 2016
    Messages:
    40
    Likes Received:
    1
    Location:
    Tucson AZ,
    Maybe I am doing something wrong. I have connected to the server several times and every time I start my phone it gives me a message that I need to connect to DJI server. so I put in my sim card from my other phone and it works great. take out the sim card and restart the phone and it starts all over again. I hope I am doing something stupid and you guys can set me straight.
     
  12. PrecisionAeroworks

    Joined:
    Feb 21, 2016
    Messages:
    261
    Likes Received:
    106
    Location:
    Colorado, USA
    Maybe it's something to do with changing the sim card. Will it verify without the sim card when connected to WiFi?
     
  13. KC4E

    Joined:
    Jan 26, 2016
    Messages:
    40
    Likes Received:
    1
    Location:
    Tucson AZ,
    It will not verify with or without the sim card if Wi-Fi is on.
     
  14. dwcola

    Joined:
    Apr 25, 2014
    Messages:
    107
    Likes Received:
    31
    I downloaded Litchi to my Samsung S5 the other day. The various parameter settings all save such as negative elevation to -656, map radius to 32,805 etc. etc. This will be fine and work ok for the field; however, I also want to use my Samsung Galaxy Tab S which I also downloaded the application two after downloading to my S5 (along with it's purchase through Google Play). For some reason, none of these settings will save so I cannot enter an altitude under 16 feet for a waypoint in mission planning, or extend the map radius beyond 1640 to 32,805? Any ideas?