Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

More help with SD card

Discussion in 'Standard/4k Discussion' started by EdOsmar, Feb 1, 2016.

  1. EdOsmar

    Dec 25, 2015
    Likes Received:
    I purchased a SanDisk microSDXC 64gb card and replaced the 8gb card. When I tried to record video, my mini ipad said the chip was not compatible. I was told all I had to do was plug in new card but it looks like I need to do something else. Any Ideas. Also when this problem is solved I will need help on downloading the videos tp my mini and compute.
  2. Shimien

    Jan 23, 2016
    Likes Received:
    Try formatting it through the go app in settings, if not that try formatting in your computer. I also think there may be a limit on how slow of a card it can except. Must be class 10 or u-1 rated to really work properly

    Sent from my iPhone using PhantomPilots mobile app
  3. Grae

    Jan 3, 2016
    Likes Received:
    Hi! Try formatting the card - find the drive in File Explorer and right click it. Choose format. Select the quick format option. Should take a good few seconds.

    Another solution may be that you don't have a fast enough card, which you will need to record 4K. In that case get a card rated 'U' which has fast write speeds. I use the Sandisk Extreme (gold and red).

    Finally, make sure you inserted the card the right way!