Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. miamijato

    Joined:
    Oct 16, 2014
    Messages:
    24
    Likes Received:
    4
    Location:
    Pembroke Pines, FL
    Just got my new Maxxrange antenna from Jake at Maxxuav, I took off the little antenna to install the larger one and as soon as I turned it on I lost the top blue light on my booster amp, it was all white instead, just the one on the left side Port 1 connection. I figured I blew the amp with this sick antenna, lol, so I check ofcourse all connections, etc.... but it wouldn't work. I then reinstall the little maxxrange antenna and wala, it works just fine again. Then I swapped it one more time to confirm and yes, I figured the antenna is just bad, Not that I'm even worried. Everybody here knows Jake is the ****.....Anyway, has anybody had this problem, Just curious, thanks everyone....Jake, I'll call you later, lol..........
     
    KyleMaxxUAV and Brad76 like this.
  2. dirtybum

    Joined:
    Apr 14, 2015
    Messages:
    3,319
    Likes Received:
    1,793
    "Jake is the S***" is that even considered a compliment?
    If your white lights on then you didn't fry the amp. You need to get it off your table and get it into the air, get some distance between it and the bird and then check back with us
     
  3. dirtybum

    Joined:
    Apr 14, 2015
    Messages:
    3,319
    Likes Received:
    1,793
    I know the gold amps are compact and light, and there's been thousands of them sold, many people have had no problems. But lately anytime someone reports a problem with amps, these gold ones seem to be at the center of it. These new panel antennas are amazing and have shown that they're capable of amazing range and penetration. I think people would be a lot better off going back to the 2015 silver amps, they are bulletproof, easy to read, just as easy to mount, and I've done many miles a boosted flights day in and day out with them, testing multiple different antennas. They just don't have the problems the gold ones do in my opinion ImageUploadedByPhantomPilots1469464839.918494.jpg
     
  4. Tripc

    Joined:
    Jun 17, 2014
    Messages:
    194
    Likes Received:
    57
    I had the exact same issue. Was using the dbs mod antenna with amp set up. Bought the maxx antenna and as soon as hooked it up. No more blue light on the left side. Except I couldn't get the blue light to come back on with the smaller antenna. Jake sent me a new amp and I hooked it back up to the set up and tried the little antenna and it worked but once again I tried the maxx antenna and sure enough. No blue light. Except this time I put on the smaller antenna and it seems to work normal.
     
  5. dirtybum

    Joined:
    Apr 14, 2015
    Messages:
    3,319
    Likes Received:
    1,793
    You guys should start requesting The silver ones
     
  6. MK47

    Joined:
    Jul 13, 2016
    Messages:
    43
    Likes Received:
    7
    Location:
    San Diego, CA
    Are the gold sunhans not compatible with the maxxrange antenna? Cause thats the setup I ordered. That sucks if i run to this issue
     
  7. dirtybum

    Joined:
    Apr 14, 2015
    Messages:
    3,319
    Likes Received:
    1,793
    All (2.4)amps are compatable! For that matter the maxxrange does pretty dang good by itself unboosted. It's on the distance leaderboard unboosted! Like I said, thousands of people have ordered that set up and have had no issues, you only hear about the ones I do have issues. I just prefer the silver ones. In fact I even have a pair of cheap Chinese black ones, that I prefer to use over the gold onesit's just one person's opinion
     
  8. MK47

    Joined:
    Jul 13, 2016
    Messages:
    43
    Likes Received:
    7
    Location:
    San Diego, CA
    I will find out tonight when I install it *cross fingers*
     
  9. Brad76

    Joined:
    May 25, 2016
    Messages:
    42
    Likes Received:
    7
    Jake IS in fact the **** dude. just sayin.. I've dealt with him and I gotta say his customer service is the best, and I'm pretty sure that's what buddy was implying by his comment, whereas you figured it was an insult.
     
    KyleMaxxUAV likes this.
  10. suck it up

    Joined:
    Apr 25, 2015
    Messages:
    324
    Likes Received:
    72
    I just got my new MaxRange and I have the same problem. No blue light on the one amp but I get both on the ITE-DBS02....

    What's up with that?

    I have the older silver ones also.
     
  11. JakeMaxxUAV

    Approved Vendor

    Joined:
    Feb 28, 2015
    Messages:
    654
    Likes Received:
    371
    Hey guys, just want to make sure you're contacting us directly when you have an issue. One way or another, we'll get you all fixed up! :) - We will start testing each amplifier kit before it goes out to make sure it's working properly. Sunhans has been notified of the issue and we are working through it. If you have any questions, feel free to ask!
     
    KyleMaxxUAV likes this.
  12. dirtybum

    Joined:
    Apr 14, 2015
    Messages:
    3,319
    Likes Received:
    1,793
    No, I knew exactly what he meant!! Jake's an awesome guy w/ great customer service!! I knew it wasnt an insult! I was joking around and YOU need to lighten up, maybe go relieve some stress by flying
     
  13. miamijato

    Joined:
    Oct 16, 2014
    Messages:
    24
    Likes Received:
    4
    Location:
    Pembroke Pines, FL
    Yes, ofcourse is jake awesome, just talked to him and another antenna is on the way, lol, lets hope it fixed the problem.Let us know MK if a problem exists with your setup, I'm curious to know......