Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Low level crash . . . Camera still works however gimbal wont move at all and camera hangs limp

Discussion in 'Pro/Adv Discussion' started by Charestpr, May 28, 2016.

  1. Charestpr

    Joined:
    May 28, 2016
    Messages:
    4
    Likes Received:
    0
    Had a low level crash today. Camera still streams video and takes video. The problem is the gimbal hangs limp and it will not move. I took it apart and see that the ribbon looks split as shown below in the pictures. Is this the problem or is that how it normally is?
     

    Attached Files:

  2. William Sokolowsky

    Joined:
    May 22, 2016
    Messages:
    5
    Likes Received:
    0
    Charestpr,
    The "quality" ribbon cables are dual layer cables. This alone is not any reason for your gimbal issue. Beyond that one would need a bit more diagnostic information to assess the issue. I unfortunately am not that person as I too am struggling with somewhat the same issue. I noticed that my pitch motor was getting hot....very hot and I could not adjust the camera tilt without help from a gentle nudge. I reset my ribbon cable as it was rubbing on the gimbal arms. I now get zero gimbal movement upon start-up and after start up but I still get video. I also now have a gimbal hardware failure error which I did not have before. I ordered a new pitch motor and ribbon cable in the hopes this will solve the problem. Next step....send for repair. Sorry to not have been of more assistance.
     
  3. William Sokolowsky

    Joined:
    May 22, 2016
    Messages:
    5
    Likes Received:
    0
    OH...I should have mentioned that when resetting my cable, I went a little animal on it making sure that corner bends were tight. I did this using a "not blunt" screwdriver. I fear I may have either shorted or broke a wire.