Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Lost video - couldn't get it back until drone power-cycled

Discussion in 'Phantom 2 Vision + Discussion' started by dpdpkpcom, Sep 16, 2014.

  1. dpdpkpcom

    Joined:
    Sep 11, 2014
    Messages:
    55
    Likes Received:
    0
    Had an interesting one just now. First flight since copper foil tape solution. Satellites were great. 9 in quite an obstructed location and 11 once airborne and beyond obstacles.

    All was fine for 10 minutes, and the drone was well on the way back and I lost video feed. I tried :-

    Coming out of the camera page and back in on my android phone
    Quitting the application and re opening
    Force quitting the application (hold home button and swipe to unload from memory)

    All the time the telemetry feeds were fine, which rules out signal issues I believe ?

    Phone is a sgs3 with cyanogenmod11 in case that's relevant.

    And to throw an extra wobbler in the mix, the second flight straight after, all was fine for the duration ?!?!?!

    Anyone experienced this before ?

    I wish i had tried stopping the recording of video and restarting that, but it didn't cross my mind at the time.

    On the plus side (excuse the pun), the second flight was my first good experience with ground station since getting the satellite fix in place and it went swimmingly.

    On my previous attempt, with intermittent satellite issues, the bird sped off in the wrong direction when I told it to come home, which scared the bejesus out of me.

    So silver lining to this cloud.

    :)

    Thoughts welcome !

    dp
     
  2. DaveMoi

    Joined:
    Jun 29, 2014
    Messages:
    72
    Likes Received:
    3
    Re: Lost video - couldn't get it back until drone power-cycl

    I had the same experience yesterday. I took a picture during the flight and the image didn't come back, instead the screen went blank. In my case it was on a iPhone...

    -David
     
  3. YeeaaBoii

    Joined:
    Jan 5, 2014
    Messages:
    145
    Likes Received:
    7
    Location:
    Athens, TX
    Re: Lost video - couldn't get it back until drone power-cycl

    It happens all the time when the preview setting is set at 640x480 at 30fps. Bump it down to 640x480 15fps or 320x240 30fps and it should come back during flight without having to power cycle.
     
  4. DaveMoi

    Joined:
    Jun 29, 2014
    Messages:
    72
    Likes Received:
    3
    Re: Lost video - couldn't get it back until drone power-cycl

    I was at 640 x 480 15 fps when it happened ..,

    -David
     
  5. dpdpkpcom

    Joined:
    Sep 11, 2014
    Messages:
    55
    Likes Received:
    0
    Re: Lost video - couldn't get it back until drone power-cycl

    Yes , me too (640x480x15fps)

    But, maybe it will help to bump it down further, will try it, thanks
     
  6. Mike Air

    Joined:
    Sep 12, 2014
    Messages:
    13
    Likes Received:
    0
    Re: Lost video - couldn't get it back until drone power-cycl

    hi,
    It happened once to me also. I took a picture and the fpv never came back until I power cycled the phantom. When I tried to change the camera settings while it was blacked out, it showed an error message saying "camera busy". I did some researches without success. Good think that I was at sight distance or otherwise I would have really disliked it. If anyone know the cause please let us know.
     
  7. DaveMoi

    Joined:
    Jun 29, 2014
    Messages:
    72
    Likes Received:
    3
    Re: Lost video - couldn't get it back until drone power-cycl

    Sounds a lot like a software bug to me...
     
  8. DrD

    DrD

    Joined:
    Aug 19, 2014
    Messages:
    107
    Likes Received:
    0
    Re: Lost video - couldn't get it back until drone power-cycl

    Just for tracking ...

    This also happened to me, yesterday. Setting 640x480 15fps. Samsung Galaxy S5. Video frozen mid-flight, telemetry ok. Restarting the application did not fix it. I continued flying it close-in, visually, w/o video preview. On next flight (fresh battery), all was well, no further problems. This has happened once before, with the higher preview settings. It has never happened to me when using the lowest preview setting (320x240 15fps). My Phantom equipment is about two months old, so twice now this has happened, and I have many flights (battery changes) experience so far.
     
  9. mede8er

    Joined:
    May 26, 2014
    Messages:
    307
    Likes Received:
    4
    Re: Lost video - couldn't get it back until drone power-cycl

    Yep...happened to me Sunday at 14, 200 ft.... :x

    This was the first flight after the Vision app update....went dead to black and never recovered all the way back although I too did all the things the OP did to get it back...did another run shortly thereafter and no probs whatsoever....gotta be the update....
     
  10. gunslinger

    gunslinger Moderator
    Staff Member

    Joined:
    Nov 3, 2013
    Messages:
    2,722
    Likes Received:
    497
    Location:
    Least Coast...
    Re: Lost video - couldn't get it back until drone power-cycl

    This also happened to me on Sunday. I took a picture and the video didn't go to black, it just locked up on the same image... I wound up landing, shutting down the P2V, shutting down the extender... turning on the extender and turning on the P2V... I put it back up in the air and couldn't replicate the problem.

    This is a P2V with an RE700 extender... So... I'm KIND OF in the right forum... :D

    -slinger
     
  11. YeeaaBoii

    Joined:
    Jan 5, 2014
    Messages:
    145
    Likes Received:
    7
    Location:
    Athens, TX
    Re: Lost video - couldn't get it back until drone power-cycl

    Yeah, the lowest setting hasn't ever given me a problem. It's a shame it can't handle it's own preview parameters.

    It's been an issue since the original Phantom Vision and yes, it does just seem like a simple software bug that could easily be fixed.
     
  12. smokiespliff

    Joined:
    Jun 18, 2014
    Messages:
    69
    Likes Received:
    2
    Location:
    Ireland
    Re: Lost video - couldn't get it back until drone power-cycl

    This was also asked in another post but didn't get a solution: http://www.phantompilots.com/viewtopic.php?f=27&t=22169

    So to be clear, this is a known problem and lowering the preview settings fixes the issue?
     
  13. mede8er

    Joined:
    May 26, 2014
    Messages:
    307
    Likes Received:
    4
    Re: Lost video - couldn't get it back until drone power-cycl

    Nope...I was in the lowest preview setting when I went black....and usually the vid returns as the bird returns...but not this time...this in my opinion was not a signal loss, it was a break in the app....
     
  14. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,416
    Likes Received:
    568
    Location:
    Sydney Australia
    Re: Lost video - couldn't get it back until drone power-cycl

    I dont know why the DJI app needs to a switch to a black screen when the photo is captured.
    It could simply just leave the FPV on and make the shutter sound and grey out the capture/record button until the SD card is ready.
    Basically leave all the processing on the bird (as is) and no need to animate the action on the FPV screen.
    I hope this makes sense DJI.
     
  15. MikeySoft

    Joined:
    Feb 21, 2014
    Messages:
    200
    Likes Received:
    1
    Location:
    Boston, MA, USA
    Re: Lost video - couldn't get it back until drone power-cycl

    Also lost video and cannot get it back! It makes no difference which of the 3 preview modes it is in.

    I’m using a Nexus 5 with Android 4.4.4 and dji app 1.0.52. They are the latest versions as of today.

    The camera works as the SD card has the videos/photo and I can even download photos using the dji app. The phantom also flys great. I just cannot see where the camera is pointed.

    I have been unable to use my PV2+ in a while and I just updated everything to the latest versions using a new laptop. Camera Ver 1.2.5g. Naza-M Ver 3.06, RC firmware 1.0.2.22, Loader 12.1.0.3. They also the latest versions as of today.

    I also had an apparent battery malfunction after the above when I was trying to investigate the problem. I’ll edit this post with a link to the battery problem after I post it.

    PS
    I'm sure the apparent battery malfunction is not related to the video problem
     
  16. DrD

    DrD

    Joined:
    Aug 19, 2014
    Messages:
    107
    Likes Received:
    0
    Re: Lost video - couldn't get it back until drone power-cycl

    Just to be clear, in my case, I have never had video problems with the preview mode SETTING at 320x240 15fps prior to start up. If I set the preview setting higher than that, when it stopped working during flight, it couldn't then be restored by simply re-setting the preview mode lower to 320x240 fps, it always required a complete power down restart. It's like a video buffer overrun issue that prevented any further video update.
     
  17. NapaEvan

    Joined:
    Sep 14, 2014
    Messages:
    8
    Likes Received:
    0
    Location:
    Napa, CA
    Re: Lost video - couldn't get it back until drone power-cycl

    I lost video a couple times, and it was simply because one of the 3 little plugs that connect to the Vision + Camera/gimbal was a little loose. Simple hardware fix: use long tweezers to carefully push the plug down.
     
  18. MikeySoft

    Joined:
    Feb 21, 2014
    Messages:
    200
    Likes Received:
    1
    Location:
    Boston, MA, USA
    Re: Lost video - couldn't get it back until drone power-cycl

    Were the videos/photos still be able to be stored on the SD card? My photos were but I'm not sure if the videos were. I'm away until next week and will check that when I return. Could you post a picture or video of the plugs you are talking about? Thanks.
     
  19. mede8er

    Joined:
    May 26, 2014
    Messages:
    307
    Likes Received:
    4
    Re: Lost video - couldn't get it back until drone power-cycl

    Just a quick update...I don't allow auto updates on my tab pro...but last weekend I did download the latest vision update and put the Samsung away until Sunday morning. Sunday morning as I was firing up the vision app prior to launch I got an update note but really didn't pay attention to it as I was out in the boondocks and the only signal around was the bird's...during that flight I got the black screen of death...but again, after power cycling I was able to fly a few short distance flights no problem....

    Last night out of curiousity I checked the vision app through app manager and got the notice..."This app is not compatible to your device"!!!! I knew from previous experience I can't download the app from Google Play, have to go through dji for some unknown reason...so you guys may want to check your app to see if you have the same conditions I did....

    TL:DR Check your vision app for device compatibility....
     
  20. easydubsit

    Joined:
    Aug 5, 2014
    Messages:
    33
    Likes Received:
    0
    Re: Lost video - couldn't get it back until drone power-cycl

    I've had a similar issue I posted about it. It seems to be an intermittent issue. When it occurs, a few power cycles and it'll correct itself. Starting to wonder if the "foil mod" has something to do with it.


    here's my post with pictures. Let me know if anyone else has a similar occurrence.
    http://www.phantompilots.com/viewtopic.php?f=27&t=24684