Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Wholeo

    Joined:
    Mar 18, 2016
    Messages:
    9
    Likes Received:
    0
    Hi Everybody,
    I just did the latest upgrade (P4) and I have no signal from my RC after the update not sure what i should do,need help
     
  2. rockydog

    Joined:
    May 25, 2015
    Messages:
    884
    Likes Received:
    251
    Location:
    London UK
    Have you updated the RC as well as the P4 ?
     
  3. rustlecrowe

    Joined:
    Mar 29, 2016
    Messages:
    136
    Likes Received:
    49
    This happened to me as well. I had lost signal, disconnected gimbal and a range of other errors. It is because either RC or aircraft is not also up to date with latest update.

    Stay in the DJI GO app and eventually you will get a blue notification saying there is a firmware update.

    Then it will all work fine once RC/Phantom are both up to date.
     
  4. Ankmax

    Joined:
    Apr 23, 2016
    Messages:
    4
    Likes Received:
    1
    I just opened the P4 and it was going along well. Then I would get a firmware upgrade notice, then it disappeared then it would come back. I upgraded the controller, now all I get is Lost Signal. Suggestions? or just wait for firmware upgrade to hopefully reappear
     
  5. MarkNH

    Joined:
    Jun 7, 2015
    Messages:
    86
    Likes Received:
    13
  6. Sim597

    Joined:
    Mar 5, 2016
    Messages:
    1,040
    Likes Received:
    266
    Lol, boy have I had some BS with this. I exchanged my P4 and my modded remote, the one I wanted and need to use for any fun, wouldn't connect, well duh! It was because the bird and RC were in different versions, took a while and a lot of cussing, but got it. My problem was even though the other P4 used same cable and MacPro, new one wouldn't update firmware, but the app did update it, now the MacPro connects.
     
  7. Ankmax

    Joined:
    Apr 23, 2016
    Messages:
    4
    Likes Received:
    1
    thanks for the replies. i fixed the issue. now i need to get the video to stop freezing. more on that if i cant get it to work. thanks again.
     
    Sim597 likes this.
  8. Big Gus

    Joined:
    May 18, 2016
    Messages:
    145
    Likes Received:
    19
    I lost my video right b4 my verginity & then the sound went out


    Sent from my iPad using PhantomPilots mobile app