Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Loosing signal at 50m

Discussion in 'Standard/4k Discussion' started by JamesG2571, Apr 12, 2016.

  1. JamesG2571

    Joined:
    Mar 1, 2016
    Messages:
    210
    Likes Received:
    91
    Hello,

    I went flying today with my buddy who also has a phantom 3 standard. we flew down in Southampton docks on the waterfront. We both did our pre flight checks, compass calibration etc.

    We then both took off and flew out over the water and then at 50m my screen went black... I could still see the bird but my video feed was dead. nothing. but my friends stock standard (windsurfer) was ok!

    I was concerned as I was using a ITElite DBS mod which I know works as I've gotten 1400m out of it (only range test I have undertaken) which was better than when i flew the same route stock.

    Could this interference be due to my friends remote knocking out my signal or could it be something else!

    any help would be great!!
     
  2. mnewxcv

    Joined:
    Apr 4, 2016
    Messages:
    269
    Likes Received:
    65
    its possible you were on a congested channel.
     
  3. JamesG2571

    Joined:
    Mar 1, 2016
    Messages:
    210
    Likes Received:
    91
    Can change the channel on the P3s?
     
  4. mnewxcv

    Joined:
    Apr 4, 2016
    Messages:
    269
    Likes Received:
    65
    I assumed so but I could be wrong. Have you tried flying again alone to see if it works normally?
     
  5. JamesG2571

    Joined:
    Mar 1, 2016
    Messages:
    210
    Likes Received:
    91
    I got 500m around a cruise ship after I moved 15m away from him but I was wondering if his remote would be the main reason for my problem.
     
  6. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    491
    Likes Received:
    114
    Location:
    Mountain City, TN
    I'm a little confused.
    You said your screen went black.
    As if the display turned off, or the app crashed, or did the live feed quit?

    Sent from my SM-N910V using Tapatalk
     
  7. JamesG2571

    Joined:
    Mar 1, 2016
    Messages:
    210
    Likes Received:
    91
    Lost video. I still had visual on the drone with my eyes so I could bring it back easily but my screen was black as I had lost video feed.


    Sent from my iPhone using PhantomPilots mobile app