Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi WP Always On POI

Discussion in 'Pro/Adv Discussion' started by Flipsonic, Jul 24, 2016.

  1. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    I created a waypoint mission and ran it this morning. I am using the latest version of Litchi IOS. Whatever I did to adjust the camera to point towards the current heading of the ac, it would always point to POI #1. There are 7 curved waypoints. For the first 5, I would like the camera to point to the heading of the ac. For the last 2, I would like the camera to point to POI #1. This is the only POI in the mission. In mission settings, I set default gimbal pitch mode to disable. I've also tried it in POI but no difference. For the 1st 5 wp, I set POI to none. I also set it to Disable but no difference. For the last 2, I set POI to POI #1. I saved it. When the mission executes, the camera would always point to POI #1. When I close the mission and open it again, wp for all POIs are set to POI#1. I even saved the mission with settings I want then closed Litchi. But when I open the mission, all POIs are set to POI #1. I removed the only POI in the mission, saved it, but when I open the mission POIs are still set to POI#1. How do I correct this? I'm sure it's something simple I overlooked.



    Sent from my iPad using PhantomPilots mobile app
     
    #1 Flipsonic, Jul 24, 2016
    Last edited: Jul 24, 2016
  2. NRJ

    NRJ

    Joined:
    Dec 18, 2015
    Messages:
    596
    Likes Received:
    141
    First in the Litchi app, once you are in the "Waypoint" mode, in mission settings. the "Heading Mode" must be set to "Waypoint Defined". From there, at each waypoint, you must either disable the gimbal pitch (will not follow a waypoint) or Focus POI (will follow POI). Use this link to learn much about Litchi and how to use it.

    Help - Litchi

    Enjoy your missions.
     
  3. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    I have Heading Mode to "Custom". I'm using the IOS version and it does not have Waypoint Defined as a choice. I does say in the manual to set it to Custom to follow the programmed heading.
     
  4. skipilot1

    Joined:
    Apr 14, 2016
    Messages:
    109
    Likes Received:
    24
    Custom in IOS is the same as waypoint defined in Android.
     
  5. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Yes I realize that. NRJ told me to put it on WP Defined but I can't because I'm using IOS.
     
  6. NRJ

    NRJ

    Joined:
    Dec 18, 2015
    Messages:
    596
    Likes Received:
    141
    Yes I believe in the iOS it is custom. Put it to that and then the rest of what I told you should be true. In the link I gave you, you have the option to choose iOS or Android for your particular version. Then it will be explained in detail with the correct words for iOS. I have an Android, that is why I said, Waypoint Defined.
     
  7. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Yes I already have that manual for IOS and read it from start to finish. As I said, I had it on Custom when I ran the mission. No matter what I changed then saved it, POI would still point to POI #1 for all WPs. It should be set to None. And when I execute the mission, camera is always pointing to POI #1 for all WPs.


    Sent from my iPad using PhantomPilots mobile app
     
  8. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Let's see if this helps. The first 2 are my Mission Setting. The last one is the WP setting. POI is still set to 1 even though I changed it to None then saved it. As you can see even though it is Disabled, the mission still executes with all WPs pointing to 1. Why won't it stay on None?[​IMG][​IMG][​IMG]


    Sent from my iPad using PhantomPilots mobile app
     
  9. NRJ

    NRJ

    Joined:
    Dec 18, 2015
    Messages:
    596
    Likes Received:
    141
    The Gimbal Pitch mode is set to disabled. It doesn't matter what number of WP it says. You can now go in and change the heading yourself manually using the heading in WP one and each one individually. Try that. As you move the slider, you should see the arrow move it's direction.
     
  10. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    My fault. I was under the impression that when I drop a WP on the map, it would automatically point towards the heading of the ac unless I choose others such as POI. I didn't even think to look at the heading for each WP on the map. Ok so I think this mission will do what I want it to do now. Thank you!


    Sent from my iPad using PhantomPilots mobile app
     
  11. NRJ

    NRJ

    Joined:
    Dec 18, 2015
    Messages:
    596
    Likes Received:
    141
    Great. Have fun. You will learn much as you fly your different missions. Especially how far away from your POI to fly etcetera. Happy mission flying.
     
  12. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Yup...this is my first mission over water. I had windsurfers on and I just went a little over a mile out this time. Signal never fell below 95%. I must say, when I saw it coming home then hovering above me...I was so impressed! Then I exhaled...LOL.


    Sent from my iPad using PhantomPilots mobile app
     
  13. NRJ

    NRJ

    Joined:
    Dec 18, 2015
    Messages:
    596
    Likes Received:
    141
    Don'tcha just love success? Congratulations.