Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi Question

Discussion in 'Standard/4k Discussion' started by Dmize, Apr 23, 2016.

  1. Dmize

    Joined:
    Apr 6, 2016
    Messages:
    25
    Likes Received:
    2
    I was running a mission at the golf course the other day. The mission ended on the 9th green, we were finishing up on number 8's green and teeing off on 9 when I heard my phantom beeping go home. Well I grab the controller and tried to take over and land it where we were. It really fought me barely changing directions and if I let off the sticks it would zoom back tore adds the home point. How do you cancel go home in litchi?


    Sent from my iPhone using PhantomPilots mobile app
     
  2. finalfantasyfan

    Joined:
    Feb 14, 2016
    Messages:
    223
    Likes Received:
    76
    Location:
    Dallas, TX
    Change mode to P to gain control should cancel the go home


    Sent from my iPhone using PhantomPilots mobile app
     
  3. PhantomPlanet

    Joined:
    Dec 17, 2015
    Messages:
    140
    Likes Received:
    41
    in my experience, it's the same as canceling it in DJI GO. go to P mode and just toggle the S2 switch until return home is cancelled.
     
    Squirrel! likes this.
  4. Dmize

    Joined:
    Apr 6, 2016
    Messages:
    25
    Likes Received:
    2
    I didn't see a return home button in litchi, going to p mode is a good idea I didn't think about


    Sent from my iPhone using PhantomPilots mobile app
     
  5. finalfantasyfan

    Joined:
    Feb 14, 2016
    Messages:
    223
    Likes Received:
    76
    Location:
    Dallas, TX
    Litchi will do one of the actions after finishing mission in the setting. Your setting was RTH so it return home after mission complete. Litchi will continue to do its assigned task(waypoints or RTH) regardless user input(even if you turn off the remote). The only way to gain control is switching S1 to P mode.[​IMG]


    Sent from my iPhone using PhantomPilots mobile app
     
    #5 finalfantasyfan, Apr 23, 2016
    Last edited: Apr 23, 2016
  6. finalfantasyfan

    Joined:
    Feb 14, 2016
    Messages:
    223
    Likes Received:
    76
    Location:
    Dallas, TX
    I think you probably mix up S1 and S2. Toggle S2(left) will trigger RTH. Toggle S1(right) will cancel RTH.


    Sent from my iPhone using PhantomPilots mobile app
     
  7. PhantomPlanet

    Joined:
    Dec 17, 2015
    Messages:
    140
    Likes Received:
    41
    my bad. i don't have a standard anymore but I could have sworn left switch was to engage and disengage RTH and right switch was to change the modes.
     
  8. finalfantasyfan

    Joined:
    Feb 14, 2016
    Messages:
    223
    Likes Received:
    76
    Location:
    Dallas, TX
    Maybe it was like that before when you had your standard but it is using S1(right switch) to disengage RTH and change modes now.
    (skip to 2:33 for RTH)
     
    PhantomPlanet likes this.
  9. Juan Wong

    Joined:
    Jan 29, 2016
    Messages:
    25
    Likes Received:
    11
    Location:
    Beaverton Oregon
    I was having this same problem with Litchi. It has been initiating an RTH every time I fly. And it will do it when flying freehand with a full battery and full signal. Every time I panicked and had to fight it away from the auto-land to land it. I was so used to having the slider switch in the Go App to cancel the RTH I forgot about the S1 switch.

    *Hey Litchi developers add a slider switch to cancel the RTH!*
     
    Dmize likes this.