Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi Magic Leash not working for me - any suggestions?

Discussion in 'Pro/Adv Discussion' started by dmark1867, Feb 28, 2016.

  1. dmark1867

    Joined:
    Dec 30, 2015
    Messages:
    235
    Likes Received:
    40
    Just posted the following on Litchi's facebook page, if anyone here has any suggestions please let me know, thanks!

    Can't seem to get the magic leash to work no matter what I do.

    Please see the images here: cubby.com

    I am using litchi android version 3.0.3 and litchi magic leash iOS version 1.0.2
    I have a Phantom 3 Advanced and I am using a nexus 7, 2nd gen 2013 running Android 6.0.1
    My nexus 7 is tethered via a Wi-Fi hotspot to my iPhone 5S The magic leash is running on an iPhone 5C Both iPhones have iOS version 9.2.1 Both iPhones are on the AT&T network and have solid LTE connections

    I double checked to make sure my phantom controller was in F-mode. I have set everything up in a way that appears to be correct, I am in a large open area, and when I have the device that is running the magic leash and it is paired start to move away from the area nothing happens, the phantom just sits there hovering above, regardless of how far away the paired device moves away.

    Also I am getting another error that happens randomly and inconsistently on the device that is running the magic leash. It says "The other device is too far", but at the time they are within a couple of feet of each otherl

    But even when it pairs and everything appears as if it should work, it still does not work.
    I am not sure what else to try to get this to work. Do you have any suggestions? Thanks
     
  2. Randy Fay

    Joined:
    Nov 14, 2015
    Messages:
    7
    Likes Received:
    0
    Location:
    Palisade, CO USA
    I had this problem! It turned out that my tethered tablet thought it was where the source tethering device (my phone) usually is. I had to change the tablet to use "Device only" as the location source. The tablet was using wifi for location in addition to GPS - why it would override GPS with wifi I have no idea. This problem broke quite a number of things on Litchi, and of course could have resulted in a fly-away, because the tablet was completely wrong about its location.
     
  3. dmark1867

    Joined:
    Dec 30, 2015
    Messages:
    235
    Likes Received:
    40
    Is this a setting I can change in litchi, away from my drone and tablet right now, you don't happen to have a screen shot do you? Thank you for following up, I am interested in trying this.
     
  4. Randy Fay

    Joined:
    Nov 14, 2015
    Messages:
    7
    Likes Received:
    0
    Location:
    Palisade, CO USA
    No, this is a setting in your location settings on your android tablet. [​IMG] (Image link: Dropbox - Screenshot_2016-03-22-17-01-14.png) You may see it listed as "Device Only" or "GPS Only".

    Litchi gets its idea of where it is based on the *tablet's* location information, so that's why this is critical.

     
  5. dmark1867

    Joined:
    Dec 30, 2015
    Messages:
    235
    Likes Received:
    40
    Randy I am glad you figured this out. How well did you get the magic leash to work for you? I was thinking it would be cool to put the phone in a backpack and have it follow me on my mountain bike (for a short distance and clear of obstacles, of course) what device are you using for your tablet and for running the magic leash. I will definitely try this but due to work and traveling I won't be able to do it for a few weeks. Thanks for the help!
     
  6. Randy Fay

    Joined:
    Nov 14, 2015
    Messages:
    7
    Likes Received:
    0
    Location:
    Palisade, CO USA
    Magic leash works great, see below, done with follow and Litchi Magic Leash, which is what happened when I finally got this problem solved.



    In this case I used an Acer Iconia One 8 B1-810-11TV 8-Inch HD Tablet, and a Samsung Galaxy S5 phone. The tablet was tethered to the phone, and the mtn biker rode off away from it carrying the S5. That of course, means it all falls apart when wifi between the two fails, but this was a pretty successful episode. Really, if you want to do "follow me" it's going to be a lot better if each device has its own data plan. (My friend's phone had no data left so he couldn't use his own phone :))

     
  7. dmark1867

    Joined:
    Dec 30, 2015
    Messages:
    235
    Likes Received:
    40
    That is so cool, that is what I am wanting to do! My setup is my nexus 7 2nd gen wifi only tethered to my iphone 5s running litchi and the magic leash on my daughters iphone 5c, both iphones are on the AT&T network. Looking forward to see if it works for me. Your friend went out of frame for just a bit and it seemed that the phantom actually was in front kind of leading instead of following, non the less very cool. I will let you know my results, when I get a chance to test
     
  8. Randy Fay

    Joined:
    Nov 14, 2015
    Messages:
    7
    Likes Received:
    0
    Location:
    Palisade, CO USA
    Yes, I think he started out riding really fast (with a bit of downhill) and then slowed down, and the P3 had to adjust then. But it came out pretty neat anyway.

     
  9. dmark1867

    Joined:
    Dec 30, 2015
    Messages:
    235
    Likes Received:
    40
    Randy have you noticed that your device wants to default back to the high accuracy mode? Not a big deal, I can just change it to device only just before launching litchi. But I have noticed it does not stick, seems like an android issue.
     
  10. Randy Fay

    Joined:
    Nov 14, 2015
    Messages:
    7
    Likes Received:
    0
    Location:
    Palisade, CO USA
    I have not noticed that but will certainly be watching for it!