Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi for Android and connectivity issues, anyone else?

Discussion in 'Standard/4k Discussion' started by Ashmai, May 2, 2016.

  1. Ashmai

    Joined:
    Apr 25, 2016
    Messages:
    23
    Likes Received:
    12
    I really like the added features of Litchi vs the standard app. However with my android (SAMSUNG S7) on initial launch it rarely ever picks up my Phantom. I close the app, reopen, close, reopen, close, reopen, reboot phone, open standard app, close, close all, rinse repeat on and on until magically it seems to load find and I get video feed.

    I'm guessing this is a problem specific to me, since I don't hear others complaining? Sometimes I waste 2% battery just trying to get it to load without a crash or with video feed.
     
  2. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    489
    Likes Received:
    113
    Location:
    Mountain City, TN
    It sounds to me like you are saying that you are struggling to get your device connected to the Phantom's WiFi. Is that correct?
    If so, try turning your RC on and leave it sit for 30 to 40 seconds. Then open your device's WiFi settings and see if it connects better.

    Sent from my SM-N910V using Tapatalk
     
  3. Squirrel!

    Joined:
    Mar 2, 2016
    Messages:
    808
    Likes Received:
    259
    I had serious connection issues until I started following this start-up proceedure:

    Tablet on

    open app

    go to wi-fi, disconnect from my home wi-fi and connect to Phantom wifi

    go back to app

    start-up drone

    VOILA!

    Works each and every time.
     
  4. Ashmai

    Joined:
    Apr 25, 2016
    Messages:
    23
    Likes Received:
    12
    Interesting, I was doing 1. Drone on. 2. RC on. 3. Wait 15s (for them to connect etc). 4. Connect phone wifi to my RC wifi. 5. Open Litchi.

    I'm going to try your sequence see if that changes anything.
     
    Squirrel! likes this.
  5. Squirrel!

    Joined:
    Mar 2, 2016
    Messages:
    808
    Likes Received:
    259
    OPPS! SORRY!!! Forgot something:

    Tablet on and booted up then,

    RC on then,


    go to wi-fi, disconnect from my home wi-fi and connect to Phantom wifi

    open app

    start-up drone

    VOILA!
     
  6. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    489
    Likes Received:
    113
    Location:
    Mountain City, TN
    The common concensus around here (and I remember in my old R/C plane days) that you never want your drone turned on without the contoller on, so the RC should be the first item turned on, and the last item turned off.

    Sent from my SM-N910V using Tapatalk
     
  7. mikep2323

    Joined:
    Oct 26, 2015
    Messages:
    261
    Likes Received:
    57
    Is it the wifi connecting or the app connecting? You can't Dji and litchi running the same time. You need to force close Dji then try opening litchi. You should try to download shut app from play store and kill all apps then try to connect and it should be fine. If you have Dji app running while trying to get litchi running you will have problems connecting. You can't just close Dji you need to force close in app manager. If you try shut app they might fix the problem.
     
    Squirrel! likes this.
  8. Ashmai

    Joined:
    Apr 25, 2016
    Messages:
    23
    Likes Received:
    12
    It even happens most of the time when restarting my phone and the first app I open is Litchi.
     
  9. Squirrel!

    Joined:
    Mar 2, 2016
    Messages:
    808
    Likes Received:
    259
    Try Shut app...
     
  10. mikep2323

    Joined:
    Oct 26, 2015
    Messages:
    261
    Likes Received:
    57
    It's happens to me also with 2 of my devices. I have s6. I use the shut app,then I turn on controller and connect to device with wifi. After connected I turn P3S on and open litchi. It doesn't connect so I press the task manager and swipe litchi to side then reopen litchi and it connects. It rarely connects the first time for me. For me it always takes 2x for me to open it to get it to connect.