Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi F Mode

Discussion in 'Control (Go, Litchi, etc..)' started by Owen S, Jul 6, 2016.

Tags:
  1. Owen S

    Joined:
    Jun 30, 2016
    Messages:
    16
    Likes Received:
    1
    Location:
    Minnesota
    Bought Litchi this afternoon, however when I fly (my Phantom 3 4K), it says it's still in P mode when my controller is clearly in F mode. I tried force quitting, resetting everything, etc. I tried it in the DJI app and it shows its in F mode when I have it switched. Any ideas?
     
  2. WilliamM

    Joined:
    May 30, 2016
    Messages:
    771
    Likes Received:
    208
    Location:
    Lancaster, Pa.
    Just got Litchi myself just the other day, so I'm not to familiar with it yet. But one thing I did find out was to make sure you have the Go app forced closed before using Litchi. Even if you reboot your phone and didn't open the Go app, make sure it's closed. At least on a android.
     
  3. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    2,601
    Likes Received:
    741
    Location:
    Australia
    Im taking a long shot guess here- the first time you use F mode in DJI go you have to click through a prompt to activate.

    You may need to do this in GO first for.it to be enabled in litchi.

    Worth a try.
     
    ldallara924 and Pharm like this.
  4. Pharm

    Joined:
    Jun 14, 2016
    Messages:
    727
    Likes Received:
    257
    Open the DJI Go app. In the settings, click on "Enable multiple flight modes". Close DJI Go. Open Litchi and try again.
     
    ldallara924 likes this.
  5. Owen S

    Joined:
    Jun 30, 2016
    Messages:
    16
    Likes Received:
    1
    Location:
    Minnesota
    I'll give these a shot tomorrow. Thanks, all!

    Phantom Pilots App
     
  6. WilliamM

    Joined:
    May 30, 2016
    Messages:
    771
    Likes Received:
    208
    Location:
    Lancaster, Pa.
    As far as I know Litchi works independently and shouldn't need the Go app for anything. Go ahead and try what others have said, and let us know if it worked. Where in the Litchi app are you saying it displays the position of the S1 switch? It only needs it to be in the F position for auto flight modes, not FPV flight. If you try to go to lets say the waypoints part of the app and it's not in F position, you'll get a message to switch it there. And once you do then the waypoints will work within Litchi. Is it not working that way for you?
     
  7. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    2,601
    Likes Received:
    741
    Location:
    Australia
    I havent said this will work. Offered as a suggestion. This wouldnt be the only setting/functionality that can only be implememented in the GO app. The SDK does not give third party developers access to all functions.
     
  8. Owen S

    Joined:
    Jun 30, 2016
    Messages:
    16
    Likes Received:
    1
    Location:
    Minnesota
    What is happening is I try to set up Waypoints and it says its not in F mode when it clearly is switched to F mode. It says it's unable to complete the mission because of this. I don't fly FPV in F mode, so that's not the issue at the moment
     
  9. GhostRdrTat

    Joined:
    Nov 4, 2016
    Messages:
    149
    Likes Received:
    40
    I know this thread is a bit old but I recently installed litchi and today wanted to try out some special functions. Tried waypoints course lock home lock etc and each time a pop-up came on screen saying I needed to switch to f mode. I clearly had it in f mode as I put switch 1 all the way down, the bar at top center stayed green and said the same thing ad it does in p GPS mode I switch switch 1 to center position and at top center it changed to yellow and said I was in atti mode but switch 1 isn't putting it into f mode. The switch is fine as it does it in go app but won't switch to f mode in litchi.
     
  10. Pharm

    Joined:
    Jun 14, 2016
    Messages:
    727
    Likes Received:
    257
    Make sure your drone is turned on (turn on power -don't start the motors). Close Litchi. Open DJI Go. Wait for it to connect. In the settings, enable Multiple Flight Modes (under Main Controller Settings). Close DJI Go. You should now be ready to rock and roll when you open Litchi.

    The reason for this is that the ability to accept autonomous commands (or pre-programmed missions) must be turned on in the drone itself. Unless they've changed something and I missed it, you can only enable this with DJI Go. Once it's enabled and you close Go, the Multiple Flight Modes setting will "stick". In other words, you don't have to enable it every time you use Litchi, just that one time. You DO have to be connected to the drone to change that setting however.
     
    #10 Pharm, Nov 25, 2016
    Last edited: Nov 25, 2016
  11. Tech

    Joined:
    Nov 5, 2016
    Messages:
    1
    Likes Received:
    0
    Take off in "P" mode then hover a few meters out/up. Now switch to "F' mode.
     
  12. mrkrag

    Joined:
    Nov 20, 2016
    Messages:
    6
    Likes Received:
    1
    I've also had DroneDeploy fail tonsee the switch mode change. Fix (for android) I found from their forums is to close out any other apps such as DJI Go and force close them from application manager. Clear application defaults. When you plug the tablet in via usb it should ask which app to use. You will have to do this every time you use a different app if you are on Android 6 or later. On prior versions you get the option of "Always" or "just once", if you frequently switch apps, choose "just once"

    If i clear defaults after I fly with an app, I can go between 3 different apps I use. Without clearing defaults, I can fly with other apps in P mode, but can't do anything in F mode, the apps just don't see the switch flip.

    Give it a try, I'm able to go between Go, Litchi, and DroneDeploy freely. Annoying to have to clear defaults every time but its the price we pay.

    Sent from my SM-N920T using PhantomPilots mobile app
     
  13. GhostRdrTat

    Joined:
    Nov 4, 2016
    Messages:
    149
    Likes Received:
    40
    Good tips thx :) I have been force closing dji go before starting litchi as I knew that was necessary. I ended up uninstalling go off of the tablet and it works now. I just flip switch 1 and it goes right into f mode and the other little things that were acting wonky in litchi have stopped also so it seems to be running hiccup free now lol knock on wood. Not sure why force closing go wasn't working for me but removing it seems to have done the trick. Thx all for all your tips:)