Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Litchi camera lag

Discussion in 'Phantom 3 Help' started by trevsdad, Feb 20, 2016.

  1. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    I'm getting a tremendous (10 to 15 seconds) amount of camera lag on the Lichi app, lag on DJI GO is normal. I'm viewing on a Lenovo Tab 2 which runs well otherwise.

    I'm guessing it's something in the settings I'm not aware of...anyone familiar with this?
     
  2. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    Tried again....really strange cause it doesn't happen with DJI GO so it can't be the tablet??
     
  3. buford

    Joined:
    Sep 26, 2015
    Messages:
    757
    Likes Received:
    146
    Judging by the number of posts about Litchi camera lag, I'd say its normal. Not that it's good, but it's normal.
     
  4. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,271
    Likes Received:
    493
    Location:
    U.S./ Canada
    I have never had lag on Go or Litchi. I'm using iOS mini 4.

    My Litchi is the ios beta however.
     
  5. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    As I mentioned above, it's running on a Lenovo Tab 2 (Android) however I have DJI GO on the same tablet and the FPV on that app runs just fine. That would seem to rule out the processor.
     
  6. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    Actually I've done a lot of searching on the forum and didn't see a lot on Litchi lag. Only thing I found that seemed to address it recommended turning off hardware sharing...can't seem to find this option on the app or the tablet.
     
  7. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,271
    Likes Received:
    493
    Location:
    U.S./ Canada
    Which phantom, wifi or lightbridge RC? I have a p3p and have video downlink BRPS set as low as possible.
     
  8. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,271
    Likes Received:
    493
    Location:
    U.S./ Canada
    It's there with a radio button/slide, titled hardware decoding, I believe.
     
  9. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    P3P with light bridge...and to your other post re: button/slide for hardware decoding, where's the switch? In the app? I can't seem to find it in settings for the app or the tablet
     
  10. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    So...I have some good news. I've solved the lag problem with the help of VC Tech, developers of Litchi (vctech@flylitchi.com)

    I couldn't find this resolution on the forum so hopefully this becomes part of the knowledge base for users of the Lenovo Tab 2 A8.

    Apparently the new version, 3.0 includes a new video codec that the Lenovo couldn't handle. They have a workaround, but I agreed not to share it, so if you run into this issue, you'll have contact VC Tech directly.

    One other note...Litchi's response to this was marvelous...quick and to the point. Kudos!
     
  11. Aaron407

    Joined:
    Dec 23, 2015
    Messages:
    55
    Likes Received:
    27
    I just tried Litchi with my P3S for the first time today. Although the autonomous flight function worked well, I also had extreme lag with my Galaxy S5. After my first flight, I measured the lag to be about 35 seconds, even when using the 4 Mbps video setting. I was in my house with the bird turned off and could still see the FPV showing from when I was carrying it outside. I'll get in touch with them to see if there's something that can be figured out, because it's totally unusable in this form.
     
  12. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,271
    Likes Received:
    493
    Location:
    U.S./ Canada
    Sorry I've missed your post. Open General settings in DJI Go app, then toggle enable hardware decoding.
     
  13. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    Thanks but this problem was with Litchi, not DJI GO
     
  14. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48

    That's odd...I thought the Galaxy S5 was one of the preferred tablets. Frankly, I'm surprised this doesn't happen more often considering Litchi's upgrade to the heavier codec and the fact that not everyone's got $400 bucks to drop on a new iPad mini.

    As I mentioned earlier, email Litchi tech support and they'll fix you up with a workaround.
     
  15. Aaron407

    Joined:
    Dec 23, 2015
    Messages:
    55
    Likes Received:
    27
    Already emailed, just waiting for a reply. Thanks for the tip in the first place :)
     
  16. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48

    They were pretty quick with me...let me know how you make out.
     
  17. skeeter

    Joined:
    Dec 2, 2013
    Messages:
    219
    Likes Received:
    9
    Location:
    Kingman, AZ.
    Starting with Litchi 3.x.x, there is no more HW/SW switch for the decoder. This is due to the latest DJI SDK usage of a different decoder or something like that. As I understand it, even the DJI GO app does not use this decoder (yet), hence, no lag on it...I could be wrong, but that's my current understanding of it. It affects others flight apps as well....anything that uses the newest DJI SDK....

    There is a thread over in the Google Litchi users group...
     
    #17 skeeter, Feb 25, 2016
    Last edited: Feb 25, 2016
  18. trevsdad

    Joined:
    Jan 7, 2016
    Messages:
    206
    Likes Received:
    48
    ...much more technical than was explained to me, but you're exactly on point. Not that I'm complaining, but it seems odd that DJI wouldn't use a codec they created. Frankly if it's gonna cause this kind of problem with certain tablets, they can keep it

    BTW...do you have a link to that thread on the Google group?
     
  19. skeeter

    Joined:
    Dec 2, 2013
    Messages:
    219
    Likes Received:
    9
    Location:
    Kingman, AZ.
    Yowsa! My guess is that the DJI GO app is not using SDK 3.x yet. They will likely let the app coders debug it for them!

    Link <<

    Please let me know if the link above doesn't get you there....:confused: