Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi App for Android - Shows Disconnected

Discussion in 'Pro/Adv Discussion' started by Acepdr, Apr 18, 2016.

  1. Acepdr

    Joined:
    Dec 16, 2015
    Messages:
    30
    Likes Received:
    5
    Location:
    Ontario, Canada
    Hello Gents:

    I am running Litchi Android App ver 3.2.1 and DJI Go App 2.7.2.

    The DJI app runs fine, I have no problems connecting or any issues since the update, however I have not been able to connect Litchi, when I start the app, it always shows Disconnected on top of the screen.

    Another item is that I log into my Litchi Account on my PC, setup a waypoint mission and SAVE it, all is fine. I can recall/load the mission from the planner on PC. When I connect the Litchi App and log into my account via wi-fi there are NO SAVED missions.

    Am I doing something wrong here. I have not been able to use the App since I purchased it, then did the firmware upgrade from 3.1.0 to 3.2.1.

    Any suggestions

    PDR
     
  2. JBG

    JBG

    Joined:
    May 15, 2015
    Messages:
    207
    Likes Received:
    41
  3. berlib

    Joined:
    Jun 7, 2015
    Messages:
    37
    Likes Received:
    16
    Location:
    Aix en Provence, France
    To connect Litchi you must follow this procedure : switch on RC, then the aircraft, wait the green light on the RC and connect your phone/tablet. When asked choose Litchi. The app should connect!
    Don't forget to force to close DJI Go before!
     
  4. beegee

    Joined:
    Apr 2, 2016
    Messages:
    31
    Likes Received:
    7
    Different to the procedure in the DJI manual, which gives RC on, launch app and turn on aircraft as the start up procedure. Just saying.
     
  5. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,983
    Likes Received:
    1,162
    Location:
    Brookeville, MD, USA
    You're not trying to load the Go app before you load Litchi, right?
     
  6. Acepdr

    Joined:
    Dec 16, 2015
    Messages:
    30
    Likes Received:
    5
    Location:
    Ontario, Canada
    Right.

    I did follow the suggestions of others and grabbed the youtube video on connecting, I followed the procedure and I GOT CONNECTED ok.

    Now the only issue I see is the logging into accounts. I can log into my account via PC, but not able to log in via tablet with ID and Password, however I can log in via Facebook.
    When I do this I see that I am logged in on tablet, but there are no saved missions to load, but they are on the Mission Planner via PC.

    Will follow up with Litchi.

    Thanks everybody for the help.

    PDR
     
  7. JBG

    JBG

    Joined:
    May 15, 2015
    Messages:
    207
    Likes Received:
    41
    As far as logging into litchi for the mission hub syncing, the option to use email/password is there but I heard many people have issues using that method so stick with Facebook credentials if you can. Also when you are logging into the app, are you hitting the button at the lop left that gives you the flight modes, at the end of the list is the login

    Sent from my Nexus 6 using Tapatalk
     
  8. Acepdr

    Joined:
    Dec 16, 2015
    Messages:
    30
    Likes Received:
    5
    Location:
    Ontario, Canada
    Yes. On the App I select top left and on the far right I see my name as logged into account.

    PDR
     
  9. wings1

    Joined:
    Jan 8, 2016
    Messages:
    27
    Likes Received:
    2
    Thanks. I was having that issue as well.

    Also, is there a library with Litchi similar to go app or can you o LT get vids/pics from the sd card?
     
  10. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    I am very frustrated with this issue also. First time I used Litchi it asked me which app to use. Now no matter what Go app comes up even if I force stop it!
     
  11. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,983
    Likes Received:
    1,162
    Location:
    Brookeville, MD, USA
    It's kinda tricky the very first time
     
  12. JBG

    JBG

    Joined:
    May 15, 2015
    Messages:
    207
    Likes Received:
    41
    That is because you set dji go as the default app, that is not a litchi error but yours. Reset the default app settings, and then from now on you ALWAYS have to choose "Just Once" when starting any app to fly the phantom.

    Sent from my Nexus 6 using Tapatalk
     
  13. HWCM

    Joined:
    May 2, 2016
    Messages:
    658
    Likes Received:
    138
    I do not have the DJI GO app installed on my phone and i still can not get it to connect.