Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Litchi and Samsung Galaxy Tab S2 not working?

Discussion in 'Phantom 3 Help' started by rene van der meer, Jul 20, 2016.

  1. rene van der meer

    Joined:
    Oct 16, 2015
    Messages:
    377
    Likes Received:
    70
    I have been struggling to get the combination of Litchi and Samsung Galaxy Tab S2 working.

    According to this thread, the combination should work.
    Because the Nvidea Shield K1 is impossible to buy and I read good experiences I decided to buy a S2.

    I have been trying several option.
    I still get a lot of errors.

    I can not get DJI Go working after I installed Litchi.
    I know I have to get them exclusive USB rights. To change between them I have to modify the settings.
    I have removed Go.

    After I turn on the RC I have to reboot the tablet.
    Otherwise I do have a connection with the drone, but get no camera image.
    Missions sometimes fail to upload.I have to restart Litchi and also the S2.

    With my mobile (S6 edge) I never have had problems with Go or Litchi.

    I am thinking about returning the S2.
    Has anyone got the combination working smoothly?
    Please give me tips to solve this.
    .
     
  2. Gulfstream

    Joined:
    May 4, 2016
    Messages:
    51
    Likes Received:
    19
    One of my devices is a Tab 2 70 still running Android 4.0 it it works just fine, though I prefer to use my OnePlusOne.
     
  3. Terryor

    Joined:
    Jul 20, 2016
    Messages:
    1
    Likes Received:
    1
    I have given up trying to get Litchi to work on my Samsung Tablet S2. I have Android 6.0.1 and no matter what I try, I can't get it to connect. I even did a factor reset and did not reinstall anything buy Litchi, still no go. And can't find anyway to contact Litchi to get a refund.
     
    rene van der meer likes this.
  4. electropappy

    Joined:
    Jun 19, 2015
    Messages:
    16
    Likes Received:
    2
    If you have DJIGo and Litchi App on your Galaxy S2 Tablet, you may have to go into your DJI GO App settings and change your default setting as this may be your problem.
    Good Luck
     
    rene van der meer likes this.
  5. rene van der meer

    Joined:
    Oct 16, 2015
    Messages:
    377
    Likes Received:
    70
    I tried that also, but no luck. I am now very happy with the Nvidea Shield.
     
  6. Dronason

    Joined:
    Aug 9, 2015
    Messages:
    498
    Likes Received:
    82
    Location:
    Switzerland
    I have also P3A with Galaxy Tab S2 Android 6.0.1. Go and Lichti installed.
    At first it didn't worked, only Go was ok but I didn't get it pop-up to choose what application to use for the USB connection, I got Go directly. I have the use to disconnect and reconnect the USB on the table to be sure to trigger the application.
    I cleared in the tablet / setup / application Go as default application and retry.
    Now when I reconnect the USB, I got the choice of the application, I selected Lichti and it connect to the drone. I just didn't get the video. If I switch to Photo then the video link is establish and stay when I switch back to Video.
    Now if I want to use Go, I quit Lichti and disconnect/reconnect the USB and ... Lichti come again, no choice. I cleared the application default for Lichti and now I get the pop-up to choose the application. But in it, there is not the choice to select on-time or always as I have always seen. Whatever you selected is save as default. From my memory this was not the case with Android 5 on the same tablet, I could switch application straight.

    So
    1) application default is set each time whatever app is selected
    2) disconnect/reconnect USB is needed

    It works somehow in my case and is just acceptable if you don't switch of application so often.

    Same on DJI forum: Litchi + DJI GO + Samsung Tab S2 Problem
     
    rene van der meer likes this.
  7. rene van der meer

    Joined:
    Oct 16, 2015
    Messages:
    377
    Likes Received:
    70
    I tried that also, but it didn't work for me with Android 6 :(
     
  8. jdh313

    Joined:
    Jul 20, 2016
    Messages:
    4
    Likes Received:
    1
    On 6.0 when you select an app on the bottom, it becomes the default, unlike in previous versions when you could do it for one time. My recommendation is when it opens, back out of that pop up and open the app from the app drawer. That should work around the issue.
    Other than that, how do you find the performance on the Tab S2? I have the same device and while it seems to work well I question if other devices work better.
     
    rene van der meer likes this.
  9. Dronason

    Joined:
    Aug 9, 2015
    Messages:
    498
    Likes Received:
    82
    Location:
    Switzerland
    Didn't work on mine, but the idea sounds good. I have to disconnect the USB cable to trigger the link. If the Go app is just open, it didn't link to it.
    If I launch the Go app without using the pop-out bottom menu (and all default cleared), it didn't connect (not blue CAMERA button).
     
    rene van der meer likes this.
  10. rene van der meer

    Joined:
    Oct 16, 2015
    Messages:
    377
    Likes Received:
    70
    I tried everything, default USB settings, etc. I only occasionally could get the S2 to work. I returned it and bought a (much cheaper) Shield (Android 5.0) . Since then no problems, but I am reluctant to switch to Android 6.0.
     
  11. Dronason

    Joined:
    Aug 9, 2015
    Messages:
    498
    Likes Received:
    82
    Location:
    Switzerland
    Yes, me too, will try to avoid it.
    By chance I normally use a Tab S 8.4 that has not Android 6. For the Tab S2 it is not an issue if I have by default Go app and at least I know now how to switch to Lichti in case I really need it.
     
  12. Kirby Johnson

    Joined:
    Jun 22, 2016
    Messages:
    99
    Likes Received:
    25
    Location:
    Sarasota FloriDuh
    Hello. I posted a similar thread a few weeks ago. I have a P3A and bought LITCHI almost immediately. I managed to get Litchi working on a LG G Stylo along with DJI Go. I also have 2 Samsung Galaxy Tab 8.4 LTE tablets along with a Note 4. I am fairly savy Android wise and tech smart and I have not been able to get Litchi to work on A N Y T H I N G except the LG phone. Contacting Litchi was worthless. "Make sure USB Debugging is enabled, blah blah blah...etc.etc." worthless stuff I had tried seventeen times already.

    It should not be that difficult to make an application work over the USB but Litchi either can not figure it out, or does not want to bother. I thought Litchi would be a great application for my Phantom, but it really gives you little more than the native DJI Go, which works just fine. The reason I have 2 identical tablets is that I was convinced that the first was defective as it would not talk to Litchi and bought a replacement only to discover it was LITCHI rather than my tablet(s).

    I had NO LUCK getting the two apps to coexist. I had decided that I would have one phone/tablet for Litchi and another for DJI Go. I have become completely disinterested in Litchi because of all this worthless bull I went through for nothing when I could have been learning to fly my drone. Your mileage may vary. :)
     
    rene van der meer likes this.
  13. Kirby Johnson

    Joined:
    Jun 22, 2016
    Messages:
    99
    Likes Received:
    25
    Location:
    Sarasota FloriDuh
    Correction Galaxy Tab S 8.4. Left off the S.
     
  14. TexasStar15

    Joined:
    Mar 20, 2015
    Messages:
    38
    Likes Received:
    7
    Location:
    Austin, Texas
    I'm running a Samsung Galaxy Tab S2 and DJI Phantom 3 4K, everything works fine with Litchi.
     
    rene van der meer likes this.
  15. rene van der meer

    Joined:
    Oct 16, 2015
    Messages:
    377
    Likes Received:
    70
    What Android version are you using and how do you switch between DJI Go and Litchi?
     
  16. TexasStar15

    Joined:
    Mar 20, 2015
    Messages:
    38
    Likes Received:
    7
    Location:
    Austin, Texas
    Latest version (whatever that is) and you have to force stop DJI Go to get it to work.
     
  17. rene van der meer

    Joined:
    Oct 16, 2015
    Messages:
    377
    Likes Received:
    70
    Thanks. The 4K has WiFi and not Lightbridge. Maybe that's the difference.
     
  18. finalfantasyfan

    Joined:
    Feb 14, 2016
    Messages:
    223
    Likes Received:
    76
    Location:
    Dallas, TX
    Have you tried changing the USB mode to "RNDIS"?
     
  19. Frank chrome

    Joined:
    Sep 9, 2016
    Messages:
    6
    Likes Received:
    0

    Hi I just bought the galaxy s2, using it in the phantom 4 and it will not connect. I don't have the dgi installed but this litchi wont connect. Did anyone find a solution on this problem
     
  20. finalfantasyfan

    Joined:
    Feb 14, 2016
    Messages:
    223
    Likes Received:
    76
    Location:
    Dallas, TX
    I have galaxy tab s2 running 6.0.1 and found solution by changing the USB mode to RNDIS. Google how to enable USB debugging on Android. And change the USB mode from MTP to RNDIS. You will need to change it every time you connect the USB because MTP is default mode.


    Sent from my iPhone using PhantomPilots