Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Linking Lithchi at 11,000 MSL

Discussion in 'General Discussion' started by Chuck G, Jul 25, 2016.

  1. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
    Hi Everyone,

    This is my first post to the Phantom forum. I have spent many hours reading the well informed posts by
    so many enthusiastic members. Now I am posting a problem that is baffling.

    I am fortunate to be in Park City, Utah this summer and have been practicing and practicing flying and creating flight plans with my Phantom. After several weeks it became obvious to me that Litchi software offers many custom features that are not available from DJI. Purchased and have used the Litchi software for the past few weeks. Now comes the problem.

    Park City is at 7,000 MSL and I have experienced no problems no problems using Waypoints, gimbal and heading settings and the host of features available. No issues. Planned a flight at Wasatch National Forest and specifically at Butterfly Lake. The Lake is at 11,000 MSL. There is no internet service that far away from
    the city so I followed the instructions of several forum members and laid out the flight at my home using the internet. I zoomed the map several times to make sure there was plenty of data stored in the cache.
    The waypoints used for the Butterfly Lake flight were between 40 and 350 meters (default max alt 500 meters). I was extra careful to check each of the 14 waypoints to make certain that all flight parameters were safe and within the capability of the software (or so I thought).
    Travelled to Butterfly Lake and fired up the bird and hovered at 3 meters and got a message that said 'altitude to high.' Landed, rechecked everything in my flight plan and tried again and again with the same error message. Then manually flew the bird and had no problem with altitude or control. So I suspect that there
    is a software problem, but it beats the heck out of me.
    I suspect not many members haven't flown at this height but hope that somebody can shed light on why it works perfectly at 7,000 MSL and not at 11,000. I'm flying a Phantom 4 and using an IOS operating system.
    Chuck Greenberg
     
    #1 Chuck G, Jul 25, 2016
    Last edited: Jul 26, 2016
  2. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,689
    Likes Received:
    3,420
    I'm not sure of the exact reason but I think it's unlikely to be related to being 11000 feet above sea level.
    The Phantom doesn't know or care how high above sea level it is.
    How high above the start point you set are the waypoints?
    What's the altitude for your start point in Litchi?
     
  3. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
     
  4. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
    I agree that it is very unlikely the Phantom caused the problem.
    My initial altitude for Wpt 1 was 40 meters, max was 350 meters.
     
  5. Sagebrush

    Joined:
    Jan 3, 2016
    Messages:
    546
    Likes Received:
    153
    I realize you're not there anymore, but it may have been worth trying a second upload. I had one mission fail when the bird flew to the first waypoint and then hovered for perhaps twenty seconds.

    SB
     
  6. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
    Next few days I'm going back. Even though the DJI Go app was closed the default altitude for Go was 70 meters. I have changed it to 500 meters and perhaps that will work? Fortunately I'm less than an hour drive away. When the link failed I tried several times and reduced the initial altitude to 40 meters.
    Using the map in the cache I programmed a short waypoint flight, but one of the wpts was over 120 meters.
     
    Pharm likes this.
  7. Pharm

    Joined:
    Jun 14, 2016
    Messages:
    711
    Likes Received:
    250
    It means the chosen altitude for at least one waypoint is higher than the max altitude set in DJI Go. Open DJI Go and change the max altitude. Close DJI and open Litchi and it'll work fine. Litchi honors the max settings in DJI Go. I had the same problem. My max altitude was set to 400 ft but one of my waypoints was set to 406 ft by mistake. Drove me crazy until I figured it out. I reset the waypoint to 396 ft. and all went fine after that.
     
    MasterBlaster likes this.
  8. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
     
  9. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
    Thank you for the post. If DJI rules (as it probably should) then the problem will be solved. Hopefully I can test it tomorrow or Wednesday. I will post the results.
    While my video and processing skills have a way to go hopefully i can upload a video.
     
  10. Pharm

    Joined:
    Jun 14, 2016
    Messages:
    711
    Likes Received:
    250
    Looking forward to seeing it. I'm afraid to fly around here lately. 98 degrees and 90 % humidity makes me nervous about me AND my Phantom.
     
  11. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
    Made the drive back to Butterfly Lake and repeated the process, but raised the upper limits of the DJI Go app to exceed my max altitude in Waypoints. It worked, almost to good. In the process of flying the wpt route I lost contact, the first few minutes I was pretty calm, but I realized I hadn't written down my takeoff time; time itself seemed to stop....but nine minutes after losing contact a beautiful thing happened...The .Phantom 4 descending directly over our final waypoint.
    Thanks for the help in diagnosing the problem and my only suggestion to anyone who takes
    the time to read this is; for any journey that may take the Phantom out of contact range be sure to write down the departure time. In fact it probably should be done for any automated flight. After 4500 hours of airplane flying you might think that I would have known that!!!!
     
    sar104 likes this.
  12. Pharm

    Joined:
    Jun 14, 2016
    Messages:
    711
    Likes Received:
    250
    Wonderful! Glad it worked. One thing to remember about time when using waypoints: if your mission is set to "straight lines" instead of "curved path", the Phantom will stop moving briefly at each waypoint before moving on. This is NOT calculated into the estimated duration of the mission. If one is not aware of this and they're pushing the battery limits based on the estimated mission duration, one could easily run out of power before the mission completes. When set to "curved path", the Phantom doesn't stop at each waypoint. It just flies right by them so the estimated mission time is more accurate (barring a sudden wind speed change, microburst, volcanic ash, pterodactyl flock, etc.)
     
    Chuck G likes this.
  13. Chuck G

    Joined:
    Apr 30, 2016
    Messages:
    8
    Likes Received:
    2
    Excellent point and not mentioned in the manual.