Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Lightbridge not working after firmware update

Discussion in 'Firmware' started by MackBoston, Nov 22, 2014.

  1. MackBoston

    Oct 27, 2014
    Likes Received:
    I updated all the air system firmware in LB assistant 1.3 and now I can no longer see the currently installed air encoder and air transmitter firmware version in the LB assistant. The main controller firmware version for the air unit still populates in the assistant program just not the transmitter and encoder firmware. I tried downgrading and reloading the main firmware on the air unit with no luck. It will no longer allow me to downgrade or upgrade the encoder/transmitter firmware or see what version it is running on the air unit. The video link is blinking red and im getting no video through the app. I am getting signal diagnostics in the app but no flight data. Control link is green and phantom responds to control inputs.
  2. spudraleigh

    Jul 23, 2014
    Likes Received:
    San Diego, CA
    Is EVERYTHING updated? By that I mean all upgradable items... What is your configuration other than the LB? Might help in troubleshooting
Similar Threads - Lightbridge working firmware Forum Date
Lightbridge Still not working with Hero 4 @4k DJI Lightbridge Oct 14, 2014
Airborne repeater for Lightbridge ?? Pro/Adv Discussion Wednesday at 12:48 AM
I think lightbridge is broken Pro/Adv Discussion Apr 14, 2017
Ocusync is better than lightbridge? Phantom 4 Discussion Apr 6, 2017
Standard Lightbridge Phantom 3 Help Apr 3, 2017