Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Light on Remote Gone / Firmware upgrade failure

Discussion in 'Firmware' started by kanook, Jun 20, 2015.

  1. kanook

    Joined:
    Jun 14, 2015
    Messages:
    3
    Likes Received:
    0
    Question. I was recalibrating my remote for my phantom 2 tonight--simple validations and checks that I do when I go to fly and haven't flown in a while. The calibration completed successfully. I noticed there was a firmware upgrade, V1.0.2.26 and proceeded to upgrade.

    The upgrade failed in the middle of the process. I received an alert message to power cycle and try again. I tried to do so, but it failed a second time. I now noticed the light on my remote no longer appears, the firmware upgrade continually fails, and when I attempted to recalibrate the remote again (just as a simple test), the recalibration won't function won't work. I've disconnected, replaced batteries, all that stuff, no change.

    Appreciate any advice or recommendation. I tried to link the remote to the phantom, not working either. Concerned that the firmware failure caused a bigger issue.

    thanks
     
Loading...
Similar Threads - Light Remote Gone Forum Date
Remote screen froze during the flight on Phantom 4 Pro Plus Phantom 4 Pro Discussion May 14, 2017
HELP new p3p remote blinks red light General Discussion Mar 10, 2017
Remote quits working mid flight Phantom 2 Vision + Discussion Feb 5, 2017
RED LIGHT ON REMOTE Phantom 1 Help Dec 18, 2016
Professional Remote Controller Red Lights + Beeping? Phantom 3 Help Dec 7, 2016