Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

[Led Indicator] Lights sequence when warming up

Discussion in 'General Discussion' started by nperic, Sep 3, 2013.

  1. nperic

    Joined:
    Aug 23, 2013
    Messages:
    25
    Likes Received:
    0
    Location:
    Buenos Aires, Argentina
    Hi guys!

    I have some doubts regarding to the lights signals of the Phantom. I been flying for three weeks now, GPS and ATTI modes, and everything is been going great! I'm really enjoying this amazing toy :D

    I been reading the manuals that are available for download in the DJI page.

    In both manuals "Phantom Quick Start Manual v1.6" and "Phantom Flying Chart v1.0" the System Start & Self-Check led flashing is:
    (R=Red;G=Green;Y=Yellow)
    R G Y R G Y R G Y G G G G

    I never got that sequence when warming up. Mine is always like these:
    R R R G R R G R G G G G G G G

    This seems to be more like GPS Signal Indicator instead of startup self-check.

    When the final 4 green lights go off, if my flight mode is in GPS the green light remains without any red lights (the same goes for ATTI but instead of green is a yellow light).

    I never got bad GPS signal (I think) and was wondering how the red lights goes, are the red lights always blinking? How do you differ GPS Bad signal from low battery?

    And the last question is about Fail-safe. Is this feature enabled from factory? How can I be sure that the home location has been saved after 8 seconds after take off? It needs to be in gps mode or been in atti with more than 6 satellites also works

    I never connected my Phantom to my computer, don't even know what firmware it has. It's been working great so far, may be this weekend I'll give it a try to home lock and course lock flight modes.

    Thanks in advance!!!
     
  2. rilot

    Joined:
    Aug 18, 2013
    Messages:
    842
    Likes Received:
    5
    Location:
    Twyford, UK
    Mine is the same as yours. I've never had the yellow when starting up.
    Only time I get yellow is if I trigger a compass calibration or I set ATTI mode.