Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Lead Battery Charge with Hitec X4

Discussion in 'General Discussion' started by xstatic, May 8, 2014.

  1. xstatic

    Joined:
    Apr 26, 2013
    Messages:
    234
    Likes Received:
    0
    Here is the setup.
    Hitec X4 battery charge, which by the way I really love.
    I have a lead acid battery 12 volts, 4.0 AH

    What should I set up the X4 charger settings for this battery.
    The battery label says 13.5 to 13.8 Volts standby
    Cycle use 14.4-15 Volts
    Initial current less than 1.2 Amps

    So how do I charge this baby.
     
  2. Ozzyguy

    Joined:
    Dec 6, 2013
    Messages:
    811
    Likes Received:
    1
    Location:
    Townsville,Australia.
    Theory says that .4 of an amp will be the optimum. If your charger won't go that low 1 amp will be fine. Being an SLA battery 14.4 is fully changed and the charger should go to float mode. After taking it off the charge it will probably stabilize around the 13.8 volt mark.
     
  3. Ozzyguy

    Joined:
    Dec 6, 2013
    Messages:
    811
    Likes Received:
    1
    Location:
    Townsville,Australia.
    Initial current refers to how much an appliance can draw on start up. Kind of like the burst rating on a LiPo.
     
  4. xstatic

    Joined:
    Apr 26, 2013
    Messages:
    234
    Likes Received:
    0
    I can also set a cut off or maximum reached, so ill set if for the 13 and the bit you suggested

    Thank for the info