Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Just installed Arris gimbal... doesnt tilt...

Discussion in 'Phantom 2 Help' started by HoverMan, May 2, 2014.

  1. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA
    Phantom 1.1.1 and installed my new arris cm2000.

    I plugged the right wires into F2 and left a single white wire unplugged, per the internet directions.

    Went into NAZA, told it I have a gimbal and when I plug the gimbals wires in it just tilts all the way straight down, making a buzzing sound, and doesnt respond to the controller.

    PLEASE help me with this.
     
  2. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    In the gimbal settings in the NAZA, did you change all the gains to 0?

    you might also have to connect the gimbal up to your computer, then using the gimbal software, change the RC control so that it's set to a mode other than "rate" (think it depends on what software it is that comes with your gimbal)
     
  3. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA
    Starting to think a gimbal was a REALLY BAD IDEA.

    Its a nightmare to install. I finally got the gimbal software to see the gimbal by downloading a chip driver. Now when the gimbal softrware connects, the gimbal goes crazy and starts having a seizure.

    Anybody have any experience with Arris CM2000 gimbals? Nothing but problems.

    Software says "ACCELEROMETER NOT CALIBRATED" Reset to defaults does nothing.
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Gizmo there probably knows as much about the Arris gimbals as anybody here. I have a CM2000 as well but didn't have the problem you're seeing...however, it sounds like a matter of just getting the gimbal calibrated before 1st use.

    1. Don't connect it to the NAZA yet, get the gimbal itself behaving properly first

    2. Look on the CD that came with your gimbal, it should have a picture file (.jpg I think) showing what settings your specific gimbal should need in the software...if you manually input the values shown in that image it should behave as expected.

    3. Do you have the gopro mounted to the gimbal when you power it on?
     
  5. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA

    My cd did not come with a picture or video. The gopro was attached when powered up. Here's a video of what happens when I turn it on.


    http://s42.photobucket.com/user/wr200/m ... e.mp4.html
     
  6. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    In that vid, it looks like you have both the Phantom and the gimbal board connected to your PC at the same time, correct? That's not a problem, I just wanted to make sure that accounts for both USB cable ends I see there.

    -Was the gimbal connected to the Phantom's power supply as well, or just to PC/USB?

    -Does it behave the same when connected only to the power supply and not to the PC/USB?
     
  7. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA

    1. I've tried it both ways. Currently, I have the gimbal unplugged from the naza. The way it is now, the phantoms battery is powering the gimbal and it still has a "seizure".

    2. Yes.

    thanks for trying to help! Its been tough dealing with this gimbal.
     
  8. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA
    Just a bump.. Any help on this for me?

    * also, mine did NOT come with a video of it being tested or an image of the stock settings.
     
  9. cjaviert

    Joined:
    Mar 11, 2014
    Messages:
    64
    Likes Received:
    0
    [youtube]http://www.youtube.com/watch?v=QTFWQFag6dI[/youtube]Got the same issue with mine and a Phantom V1.1.1, justo to make short my story I ended up sending back the gimbal for a refund and bought a Tarot. The vendor told me I might something wrong with the crontroller board.
     
  10. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA
    Getting a little frustrated because Hobby Wing is not responding to my help emails. That's really not cool.
     
  11. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    I wish I could help you more, but I have one of the older revisions of the CM2000 with the Martinez control board...I'm assuming yours has the AlexMos board on it, so I don't know if any of my settings or other advice would help. Mine does act up every now and then, jerking around when I first turn it on, but I've found that holding it even semi-level with my fingertip and power-cycling it a couple of times usually clears it right up.
     
  12. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA

    I just emailed them, again, this time to every single email address listed on their website. 6 or 7 people total. Maybe I'll get a response.
     
  13. JesterR1

    Joined:
    May 7, 2014
    Messages:
    41
    Likes Received:
    0
    Morning Hoverman, I ran into the exact same issue you did last night when I got my gimball. First off, on the CD they sent you there should be a document titled Ariss 2000 stock file, or something to that effect. Save that to your computer. Now-

    Hook up the NAZA cable and plug the battery cable in. Then connect the mini USB to the computer and click connect.

    Once you are talking to the gimball, go to the top right and click load, and find that profile you saved, (note that you might have to select all files to see it). This should put it back to the setting they set it with

    Once you have done this, grab a hold of the gimball and center it as best you can by hand. You'll feel it trying to pull away slightly but try to hold it still. At this point I did the accel calibration 3 times. Literally hit the accel calibration button, let it do its thing for 3-4 seconds, then did it again, then did it a third time.

    This should get the gimball level and stop the seizure effect you see.

    My only issue is now I can't get the gimball to pitch forward, but I assume that is because I am not zeroed on the 7th channel of the transmitter. Need to figure that out
     
  14. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA


    THANKS! I will try this tonight.
     
  15. JesterR1

    Joined:
    May 7, 2014
    Messages:
    41
    Likes Received:
    0
    Did that do the trick?
     
  16. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA

    Sorry - been working nothing but 12+hr days. I'm just now getting a chance to attack this.

    Well, I think I made some progress. White wire unplugged + red/black wires plugged into f2 seems to work. On the gimbal program, the key is to hit "write" after each change.

    So, now that big concern the the tilting of the gimbal. Its CONSTANTLY in motion. Hard to get it to stay at say, a 30 degree angle. Its so sensitive and moves so fast. Faces straight down all the way up to 20 degrees up or so.

    So if I can make the tilting more predictable, slower and steady, then I'll be good to go. I think.

    http://s42.photobucket.com/user/wr200/m ... 8.mp4.html

    Also, I hate the way the Velcro attaches. Please tell me there's a better way.
     
  17. JesterR1

    Joined:
    May 7, 2014
    Messages:
    41
    Likes Received:
    0
    Yes, I only have the pitch wire plugged in as well to the NAZA. Yes, hitting the write key makes a difference!

    Also there is a way to fix your angle of the gimball. If you leave it checked in speed mode, then you will have that issue. Instead for pitch , where you set the degree of movement you want, change it to angle mode.....hit write. Then re calibrate the home position like mentioned before. This will solve your pitch issue.
     
  18. HoverMan

    Joined:
    Mar 12, 2014
    Messages:
    119
    Likes Received:
    0
    Location:
    SC, USA
    Can you take a picture of your rc settings? Also a pic of your naza gimbal settings. This thing... somethings off.
     
  19. JesterR1

    Joined:
    May 7, 2014
    Messages:
    41
    Likes Received:
    0
    Sure, it will be sometime tonight, but I'll get what I can for you.
     
  20. JesterR1

    Joined:
    May 7, 2014
    Messages:
    41
    Likes Received:
    0
    Hoverman take a look here and let me know if you need me to add more....

    http://www.r1jester.com/quad.html


    *Edit - Also just thought of something, make sure your transmitter is turned on. If you have it off, there is no signal being sent out and the gimbal will roll and wander around.