Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Just got new Pro, firmware upgrade fail...hrrrmm

Discussion in 'Pro/Adv Discussion' started by Jarod, Dec 15, 2015.

  1. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
    Hi All,

    Just got a P3 Pro and tried updating the firmware on the bird last night. Went through all the proper procedure, had the correct blinking green/red lights and noises. Waited at least 25-30 minutes and saw that the green/red lights stopped blinking and the sound became a steady screech so I powered off. Text file on SD card said the update failed. Retrying today and I can't even get it to go into firmware upgrade mode. It begins to make the correct noises and green/red lights but after 30 seconds or so..switches to red.

    Also the app on my phone had asked to update firmware on the controller and I was able to update correctly, but there's still a red "No Signal" at the top which I was hoping the controller update would at least fix this. Any ideas?

    • Additional details:
    • This is for the Nov 25th firmware 1.05.
    • Formatted the SD card w/ exfat on my computer
    • Formatted the SD card using the controller
    • Also tried a different SD card

    Here is a video of the upgrade process failing:

     
    #1 Jarod, Dec 15, 2015
    Last edited: Dec 15, 2015
  2. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    The No Signal is normal until your phantom is running and connected.
    The Youtube Video is set to private so we can't see it.
    How are you formatting the card via controller - do you mean from th eapp?
    That's ideal but should be OK done in computer.
    Are you 100% sure it's the right file you downloaded, unzipped and only the unzipped file put on the card.
     
  3. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,970
    Likes Received:
    1,115
    Location:
    Yorba Linda, CA
    Jarod, What do you say we all come over to your house in Malibu and figure this problem out, have a little party? What's for dinner?

    upload_2015-12-15_12-6-36.png
     
    #3 John Locke, Dec 15, 2015
    Last edited: Dec 15, 2015
  4. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
    I can fly the phantom so it's running and can connect, just no video feed. I tried formatting all various ways mentioned. I did it on my mac and and also was able to do it from the controller. I'm sure it's the right file as it's the .bin file from the zip and I placed it in the root.


    Youtube video is now not private.
     
  5. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
    Heh some ramen for dinner!
     
  6. TrynFlyn

    Joined:
    Nov 4, 2015
    Messages:
    139
    Likes Received:
    42
    Check your log file as described in this post.
    First no video downlink, now P3P fails repeated update attempts. Help! | Page 2 | DJI Phantom Forum

    and then continue reading the rest of that thread.
     
  7. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
  8. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
    Where can I go to see what firmware version is already on the phantom? Could it be possible that since mine just came that it already has the latest hence failing the upgrade?
     
  9. TrynFlyn

    Joined:
    Nov 4, 2015
    Messages:
    139
    Likes Received:
    42
    Check the "about" section of settings in the GO app - with everything connected and on - like you're ready to fly.

    Not likely already updated to 1.5.3
     
  10. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
    Ok here's what I see in the app (just tried ios app to see if the problem exists with no video connection and still does.

    [​IMG]
     
  11. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
    Located the hidden log file. Looks like I'm getting the same problem as the others with possible device failures:

    [00014234][01 00] Firmware upgrade finished successfully.
    [00014352]Done.

    [00014384]Packet [C:\P3X_FW_V01.05.0030.bin] resumed, card sn [0x285070ed].
    [00014427]Packet vlink 01.05.0030 <-> 01.04.0010.
    [00014490]Version checking[2]...
    [00014553][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00014738][03 06][00] v2.1.6.18 -> v2.4.0.5 need upgrade.
    [00014882][04 00][00] v1.38.0.0 -> v1.41.0.0 need upgrade.
    [00014997][11 00][00] v1.6.1.0 -> v1.7.0.0 need upgrade.
    [00015087][12 00][00] v1.8.0.0 -> v1.10.0.0 need upgrade.
    [00015167][12 01][00] v1.8.0.0 -> v1.10.0.0 need upgrade.
    [00015252][12 02][00] v1.8.0.0 -> v1.10.0.0 need upgrade.
    [00015332][12 03][00] v1.8.0.0 -> v1.10.0.0 need upgrade.
    [00027864][15 00][00] device not detected.
    [00027962][17 00][00] v1.1.1.2 -> v1.1.1.7 need upgrade.
    [00028207][17 01][00] v1.0.2.4 -> v1.0.2.7 need upgrade.
    [00028357][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00028389][01 00][05] v1.26.4315 -> v1.26.4315
    [00028418][01 01][00] v1.6.2736 -> v1.26.4315 need upgrade
    [00040967][08 00][00] device not detected.
    [00041025][09 00][00] v1.7.0.3 -> v2.13.0.0 need upgrade.
    [00041057]Done.

    [00041089]Firmware upgrading[2]...
    [00041229][01 01] Firmware upgrade start...
    [00071486][01 01] Firmware upgrade finished successfully.
    [00071540][12 00] Firmware upgrade start...
    [00136649][12 00] Firmware upgrade finished successfully.
    [00136702][12 01] Firmware upgrade start...
    [00212079][12 01] Firmware upgrade finished successfully.
    [00212125][12 02] Firmware upgrade start...
    [00283079][12 02] Firmware upgrade finished successfully.
    [00283125][12 03] Firmware upgrade start...
    [00354461][12 03] Firmware upgrade finished successfully.
    [00354518][17 00] Firmware upgrade start...
    [00472562][17 00] Firmware upgrade finished successfully.
    [00472608][17 01] Firmware upgrade start...
    [00544307][17 01] Firmware upgrade finished successfully.
    [00544348][11 00] Firmware upgrade start...
    [00597502][11 00] Firmware upgrade finished successfully.
    [00597719][03 06] Firmware upgrade start...
    [00941385][03 06] Firmware upgrade finished successfully.
    [00941447][09 00] Firmware upgrade start...
    [00995094][09 00] Firmware upgrade finished successfully.
    [00995151][04 00] Firmware upgrade start...
    [01054000][04 00] Firmware upgrade finished successfully.
    [01054037]Done.

    [01054069]Version checking[3]...
    [01054141][03 05][00] v34.2.0.9 -> v34.2.0.9
    [01054226][03 06][05] v2.4.0.5 -> v2.4.0.5
    [01054280][04 00][05] v1.41.0.0 -> v1.41.0.0
    [01054380][11 00][05] v1.7.0.0 -> v1.7.0.0
    [01054449][12 00][05] v1.10.0.0 -> v1.10.0.0
    [01054534][12 01][05] v1.10.0.0 -> v1.10.0.0
    [01054614][12 02][05] v1.10.0.0 -> v1.10.0.0
    [01054690][12 03][05] v1.10.0.0 -> v1.10.0.0
    [01067227][15 00][00] device not detected.
    [01067311][17 00][05] v1.1.1.7 -> v1.1.1.7
    [01067440][17 01][05] v1.0.2.7 -> v1.0.2.7
    [01067489][19 00][00] v1.0.8.96 -> v1.0.8.96
    [01067527][01 00][05] v1.26.4315 -> v1.26.4315
    [01067557][01 01][05] v1.26.4315 -> v1.26.4315
    [01080090][08 00][00] device not detected.
    [01080130][09 00][05] v2.13.0.0 -> v2.13.0.0
    [01080162]Packet upgrade failed at version checking.



    [00016013]========== remo-con disconnect. boot(15) ============
    [00016049]Packet [C:\P3X_FW_V01.05.0030.bin] detected, card sn [0x285070ed].
    [00016083]Packet upgrade start...

    [00016120]Packet checking...
    [00016155]Packet vlink 01.05.0030 <-> 01.04.0010.
    [00016222]Done.

    [00016255]Version checking[1]...
    [00016318][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00016398][03 06][00] v2.4.0.5 -> v2.4.0.5
    [00016442][04 00][00] v1.41.0.0 -> v1.41.0.0
    [00016557][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00016647][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00016736][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00016811][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00016911][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00029444][15 00][00] device not detected.
    [00029527][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00029657][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00029719][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00029753][01 00][00] v1.26.4315 -> v1.26.4315
    [00029882][01 01][00] v1.26.4315 -> v1.26.4315
    [00042424][08 00][00] device not detected.
    [00042479][09 00][00] v2.13.0.0 -> v2.13.0.0
    [00042515]Packet upgrade failed at version checking.



    [00017076]========== remo-con disconnect. boot(15) ============
    [00017107]Packet [C:\P3X_FW_V01.05.0030.bin] detected, card sn [0xc546503e].
    [00017144]Packet upgrade start...

    [00017176]Packet checking...
    [00017207]Packet vlink 01.05.0030 <-> 01.04.0010.
    [00017268]Done.

    [00017302]Version checking[1]...
    [00017382][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00017461][03 06][00] v2.4.0.5 -> v2.4.0.5
    [00017498][04 00][00] v1.41.0.0 -> v1.41.0.0
    [00017639][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00017710][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00017811][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00017887][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00017986][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00030514][15 00][00] device not detected.
    [00030607][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00030727][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00030779][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00030814][01 00][00] v1.26.4315 -> v1.26.4315
    [00030845][01 01][00] v1.26.4315 -> v1.26.4315
    [00043377][08 00][00] device not detected.
    [00043437][09 00][00] v2.13.0.0 -> v2.13.0.0
    [00043467]Packet upgrade failed at version checking.



    [00015006]========== remo-con disconnect. boot(15) ============
    [00015042]Packet [C:\P3X_FW_V01.05.0030.bin] detected, card sn [0x285070ed].
    [00015074]Packet upgrade start...

    [00015119]Packet checking...
    [00015154]Packet vlink 01.05.0030 <-> 01.04.0010.
    [00015217]Done.

    [00015253]Version checking[1]...
    [00015332][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00015411][03 06][00] v2.4.0.5 -> v2.4.0.5
    [00015458][04 00][00] v1.41.0.0 -> v1.41.0.0
    [00015571][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00015662][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00015751][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00015851][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00015926][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00028546][15 00][00] device not detected.
    [00028621][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00028742][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00028797][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00028835][01 00][00] v1.26.4315 -> v1.26.4315
    [00028869][01 01][00] v1.26.4315 -> v1.26.4315
    [00041402][08 00][00] device not detected.
    [00041459][09 00][00] v2.13.0.0 -> v2.13.0.0
    [00041494]Packet upgrade failed at version checking.



    [00015552]========== remo-con disconnect. boot(15) ============
    [00015593]Packet [C:\P3X_FW_V01.05.0030.bin] detected, card sn [0x285070ed].
    [00015630]Packet upgrade start...

    [00015671]Packet checking...
    [00015712]Packet vlink 01.05.0030 <-> 01.04.0010.
    [00015779]Done.

    [00015814]Version checking[1]...
    [00015888][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00015968][03 06][00] v2.4.0.5 -> v2.4.0.5
    [00016012][04 00][00] v1.41.0.0 -> v1.41.0.0
    [00016123][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00016203][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00016282][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00016382][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00016456][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00028993][15 00][00] device not detected.
    [00029073][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00029197][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00029253][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00029291][01 00][00] v1.26.4315 -> v1.26.4315
    [00029329][01 01][00] v1.26.4315 -> v1.26.4315
    [00041867][08 00][00] device not detected.
    [00041933][09 00][00] v2.13.0.0 -> v2.13.0.0
    [00041971]Packet upgrade failed at version checking.



    [00015284]========== remo-con disconnect. boot(15) ============
    [00015319]Packet [C:\P3X_FW_V01.05.0030.bin] detected, card sn [0x285070ed].
    [00015355]Packet upgrade start...

    [00015391]Packet checking...
    [00015435]Packet vlink 01.05.0030 <-> 01.04.0010.
    [00015500]Done.

    [00015535]Version checking[1]...
    [00015600][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00015682][03 06][00] v2.4.0.5 -> v2.4.0.5
    [00015723][04 00][00] v1.41.0.0 -> v1.41.0.0
    [00015816][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00015996][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00016070][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00016151][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00016226][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00028779][15 00][00] device not detected.
    [00028867][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00028991][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00029048][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00029084][01 00][00] v1.26.4315 -> v1.26.4315
    [00029125][01 01][00] v1.26.4315 -> v1.26.4315
    [00041658][08 00][00] device not detected.
    [00041727][09 00][00] v2.13.0.0 -> v2.13.0.0
    [00041772]Packet upgrade failed at version checking.



    [00015121]========== 2015.12.15 19:54:47. boot(15) ============
    [00015170]Packet [C:\P3X_FW_V01.05.0030.bin] detected, card sn [0x285070ed].
    [00015203]Packet upgrade start...

    [00015247]Packet checking...
    [00015284]Packet vlink 01.05.0030 <-> 01.04.0010.
    [00015348]Done.

    [00015383]Version checking[1]...
    [00015463][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00015522][03 06][00] v2.4.0.5 -> v2.4.0.5
    [00015564][04 00][00] v1.41.0.0 -> v1.41.0.0
    [00015679][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00015753][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00015828][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00015909][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00015996][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00028534][15 00][00] device not detected.
    [00028611][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00028726][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00028785][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00028820][01 00][00] v1.26.4315 -> v1.26.4315
    [00028862][01 01][00] v1.26.4315 -> v1.26.4315
    [00041398][08 00][00] device not detected.
    [00041467][09 00][00] v2.13.0.0 -> v2.13.0.0
    [00041503]Packet upgrade failed at version checking.
     
  12. Rodger

    Joined:
    Dec 13, 2015
    Messages:
    38
    Likes Received:
    9
    Location:
    Mobile, Alabama
    Onethings you might check is the "UnZip" utility you are using. I had an older version of WinZip on my Updated Win10 Computer and had to get a newer version of Win Zip. If your aircraft started the update and then failed, the most likely culprit is a corrupted.bin file. I would download the Zip file again,insure that you are using a reliable "UnZip" utility and try again.
     
  13. clintgeaney

    Joined:
    Sep 28, 2015
    Messages:
    29
    Likes Received:
    4
    Location:
    Australia
    I updated recently to 1.5.0030.

    I completed the update and reboot the Phantom as usual.

    It gave me the sound that indicated the firmware update was done.

    When I rebooted the Phantom the gimbal went limp and all lights went out, no startup sounds and it just beeped forever. It was dead.

    I looked at the logs and it still said upgrading...

    The solution was.

    I reformatted the sd card using the Go App.

    I did this because I use a Mac and I've heard of issues with formatting from a Mac.

    Dropped the bin file update on the card again.

    It did the same thing. Gave me the sound that the update was done but still beeped with no lights.

    So I left it for around 10 mins after the update was telling me it was done.

    After around 10 mins all went quiet.

    I rebooted and the log file said all good and the update was done.

    Update was successful.

    This Worked for me. Cheers
     
  14. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,852
    Likes Received:
    660
    Location:
    Warrenpoint, Ireland
    Macs automatically unzip the files.
     
  15. Jarod

    Joined:
    Dec 15, 2015
    Messages:
    11
    Likes Received:
    0
    Yep, my mac auto unzips, but also tried 3rd party. Also formatted the SD card both in my computer and through the controller.

    I'm shipping this back to the merchant for a replacement.