Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Just downloaded the newest Go App and...

Discussion in 'Pro/Adv Discussion' started by Bateman233, Aug 14, 2015.

  1. Bateman233

    Joined:
    Apr 29, 2014
    Messages:
    91
    Likes Received:
    3
    And now it's saying my aircraft needs to be upgraded? I am current on my firmware (1.3.2)...Is this a common issue? I just double checked the DJI website and there are no new releases. I updated to 1.3.2 last week and have flown several times on the firmware.
     
  2. scooterchris

    Joined:
    Jul 30, 2015
    Messages:
    101
    Likes Received:
    11
    It seems to be there is a 1.4.0 firmware and a new version of the go app aswell
     
  3. Bateman233

    Joined:
    Apr 29, 2014
    Messages:
    91
    Likes Received:
    3
    Looking at their site now and there is no 1.4.0....Not to complain...but bloody hell these firmware updates are getting annoying.
     
  4. platypus65

    Joined:
    Jul 28, 2015
    Messages:
    13
    Likes Received:
    5
    Location:
    Concord, CA
    I had the exact same thing last night. Once I unplugged my USB cable and plugged it back in the aircraft needs to be updated message went away.
     
  5. RedHotPoker

    Joined:
    May 3, 2015
    Messages:
    3,972
    Likes Received:
    1,364
    Location:
    Edmonton Alberta
    Updated my Phantom 3 Go App today, so far, so good.
    I do hope it continues to fly flawless for me... ;-)

    RedHotPoker
     
  6. Bateman233

    Joined:
    Apr 29, 2014
    Messages:
    91
    Likes Received:
    3
    Well I did the unplugging the cable thing and it worked! Thank you...makes no sense why that'd work but it did.