Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional just bought p3 dji go app says its not compatible with device I am using iPad 8.4.1

Discussion in 'Phantom 3 Help' started by PeeWee, Aug 28, 2015.

  1. PeeWee

    Joined:
    Aug 28, 2015
    Messages:
    2
    Likes Received:
    0
    Help Please
     
  2. PeeWee

    Joined:
    Aug 28, 2015
    Messages:
    2
    Likes Received:
    0
  3. madgitty

    Joined:
    Jul 14, 2015
    Messages:
    185
    Likes Received:
    32
    Which ipad?
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
    For Apple devices, you must have a device with at least an A7 or A8 processor. For iPads, that means you'll need an iPad Mini 2, iPad Mini 3, iPad Air, or iPad Air 2.
     
  5. thestone11

    Joined:
    Mar 3, 2015
    Messages:
    296
    Likes Received:
    32
    Location:
    Alberta Canada
    Looks like you have an older iPad.