Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. desert phantom

    Joined:
    Jan 8, 2017
    Messages:
    34
    Likes Received:
    6
    As per the title, my controller won't connect. It started doing it intermittently, no it won't connect at all.

    It disconnected it while I was flying today about 500 meters away. The P4P came home, but couldn't land (I took off on a boulder). I hand caught it, but couldn't throttle it off, since the controller refused to connect. Tried turning the battery off, but didn't work either. Eventually shut it self off though while I was holding it (must have thought it had 'landed').

    Now trying to get the RC to connect again.

    I have tried powering on and off multiple times.

    I have tried trying to manually rebind, but no success.

    Have tried to refresh the firmware, but this don't work.

    I guess the remote controller is buggered?

    Just arrived on holiday in the beautiful Seychelles and bummed that my expensive drone won't work.

    Any tips appreciated!
     
Loading...