Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Ive had nothing but problems...

Discussion in 'Phantom 2 Discussion' started by Djinn, Dec 6, 2015.

  1. Djinn

    Joined:
    Nov 15, 2015
    Messages:
    53
    Likes Received:
    2
    First problem was prop guards hittting blades and causing a crash. Second problem is i find my gimbal is bent. Now, a couple flights after i bent my gimbal back, it starts making a horrible scratching noise and the top motor overheats. Also, now my fpv setup suddenly stopped working. All of this in the span a couple months. How do you guys do it.? I cant afford to keep throwing money into this thing...
     
  2. au01st

    Joined:
    Sep 15, 2015
    Messages:
    150
    Likes Received:
    25
    Don't crash?

    Which gimbal do you have? The H3-2D you can replace all the mounts, but the 3D the lower mount is attached. Unfortunately, if it's bent, you may have damaged the motor as well. I had to send mine in for repair (bought it used crashed with a whole package deal). Came back good as new.

    What is the issue with the FPV setup? It doesn't stop working for no reason. Was the transmitter unit ever powered on without the antenna?
     
  3. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    You may have pushed the arm to the third motor to close to the lower mounting bracket and it's rubbing against it. There is a allen set screw on the arm loosen it and move it down the shaft and you may have to center it a few times before you get it dead center. Here is a photo of that set screw. That's a metric allen screw.
    IMG_0024.jpg
     
    Mako79 likes this.
  4. Djinn

    Joined:
    Nov 15, 2015
    Messages:
    53
    Likes Received:
    2
    Thanks! I was abke to fix my gimbal and suddenly my fpv system started working.