Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Its back to DJI

Discussion in 'Pro/Adv Discussion' started by AbsPapa, Jun 27, 2015.

  1. AbsPapa

    AbsPapa Guest

    My P3P was flying but not like it did when I first got it. I updated the firmware and it started flying very erratically. Not acceptable to me. So DJI in LA said something is wrong, send it back to us. So I did. Cost me $54 to send it back. DJI says it will take six weeks to get it back. I have no idea if it will be fixed, exchanged, come back to me the same or worse. Now, most I'm told are working just fine, or, they think I'm just critical and a perfectionist, I should get over it.

    To cut to the chase. If you are undecided about buying one of these because of the complaints you are reading about, buy one or don't buy one. It's that simple. You have to decide. Should you desire to know more about my defunct P3P, hit me back.
     
  2. Morphious

    Joined:
    Jun 19, 2015
    Messages:
    205
    Likes Received:
    83
    I received my P3P last week, many gimbal issues, sent it back via Amazon next day, ordered another one, should be here Wednesday, if it is a problem, I give up on P3 and stay with my old reliable P2V3.
     
    AbsPapa likes this.
  3. AbsPapa

    AbsPapa Guest

    Keep us posted.
     
  4. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,209
    Likes Received:
    906
    Location:
    Indy, USA
    I'm basically in the same situation you're in. Only difference is I'm not sending my quad back and not have it for 8 weeks which includes the shipping to and from. I sent a vPlus in for warranty 6 months ago during a time when turn around was 10-14 days and did not receive my quad until 2 months later. That was with doing NO repair and selling me a $550 refurb which was junk and fell from the sky.

    My P3P was perfect and rock solid prior to updating the firmware. After the update, my P3P had 6 issues that I submitted with dji support. They responded and had me remove the app and install it again, and then recalibrate the gimbal. This indeed fixed my gimbal issue but nothing else. I opened another claim asking why they ignored the following issues, they took two days to respond back and told me to call tech support and get a RMA and send it in for repair.

    I fill confident my firmware update become corrupt when loading it. And now since you can not load current or older firmware, I'm not going to send my quad to sit in house 6 weeks just to reinstall the firmware again. I'll wait and see what takes place from the upcoming update. If it turns out to cure the situation, I wont do anymore updates.
     
    AbsPapa likes this.
  5. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    I just did a huge video shoot of a golf course with the P3P and had absolutely zero issues (I am on latest firmware etc). I don't discount anyone here who says they have had issues... just wanted to offer that I have been very happy with mine. I did experience a weird disconnect issue for about a day after the firmware update... but I re-linked my controller and it seems to have gone away...
     
  6. Tino_A

    Joined:
    Apr 8, 2015
    Messages:
    41
    Likes Received:
    11
    I think its a bug in the new software that they're not willing to admit and push a quick fix for. Too many variables probably that cause the issue to show up.

    I noticed issues as soon as I updated to 1.2.6 and regretted doing it immediately. For now the P3 is having a rest till a new firmware comes out which I'll most likely try right away. Once a new stable version is out I'm not touching it again until unless its 100% necessary.
     
    AbsPapa likes this.