Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Itelite DBS02 defect?

Discussion in 'Pro/Adv Discussion' started by Paul A Byers, Sep 23, 2016.

  1. Paul A Byers

    Joined:
    Jul 29, 2016
    Messages:
    155
    Likes Received:
    23
    I have a P3P. I bought an Itelite DBS02 range extender and installed on my original remote. When I turned it on flashing red light and just continuously beeped. So, I thought my bad. Maybe I did something wrong. I bought another remote and installed it on the new one. Same **** thing. Needless to say, I am highly discouraged and about to give up on flying. This can get rather expensive. The thrill is gone. I was extremely careful on both installs. Can't imagine I would have messed up twice. Anyone have experience with a defective DBS02?

    Thanks
     
  2. TheLightSpeedz

    Joined:
    Jan 24, 2016
    Messages:
    1,186
    Likes Received:
    366
    So I might be wrong, but I believe what your seeing is it needing a stick calibration!

    Does it connect to the bird? Can you see the camera in the Go app?

    Mine beeped like crazy too, and finally I realized it wanted a calibration!


    Sent from my iPhone using PhantomPilots
     
  3. Ken Nash

    Joined:
    Feb 8, 2016
    Messages:
    67
    Likes Received:
    24
    Location:
    High Wycombe, Buckinghamshire, England
    Have you paired the remote controller P3P?
     
  4. TheLightSpeedz

    Joined:
    Jan 24, 2016
    Messages:
    1,186
    Likes Received:
    366
  5. Paul A Byers

    Joined:
    Jul 29, 2016
    Messages:
    155
    Likes Received:
    23
    It will not pair
     
  6. Paul A Byers

    Joined:
    Jul 29, 2016
    Messages:
    155
    Likes Received:
    23
    It will not connect to the bird. I tried stick calibration and that did not fix the problem.
     
  7. TheLightSpeedz

    Joined:
    Jan 24, 2016
    Messages:
    1,186
    Likes Received:
    366
  8. TheLightSpeedz

    Joined:
    Jan 24, 2016
    Messages:
    1,186
    Likes Received:
    366
    Okay... I see. Have you tried a hard reset on the controller and then paired it?

    Also you need to update the FW on both to make sure that's not the issue


    Sent from my iPhone using PhantomPilots
     
  9. TheLightSpeedz

    Joined:
    Jan 24, 2016
    Messages:
    1,186
    Likes Received:
    366
    Even if the antenna was flawed, it would still connect probably unless it got ran over. These are pretty robust.

    I would update FW on both, do a reset on the controller (serious of button presses), then repair


    Sent from my iPhone using PhantomPilots
     
  10. shockwave199

    Joined:
    Dec 19, 2014
    Messages:
    1,066
    Likes Received:
    405
    Information description is pretty thin, op. I'm guessing the bird is flashing red? You must have some connection if you could try stick calibration. Lack of information is too confusing. You could have a bad cable or antenna, or you might have broken a cable or cable connector on your first attempt and that's why the same thing is happening to the second remote. I'd reach out to support for the kit. They'll know best.