Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

It happened to me Fly Away....

Discussion in 'Phantom 2 Discussion' started by Detroit, Jul 4, 2014.

  1. Detroit

    Joined:
    May 6, 2013
    Messages:
    118
    Likes Received:
    28
    Location:
    Ann Arbor MI
    Well this isn't good I have 46 flights on my P2 H3 3d and every flight has been perfect until yesterday. Im not going to name anyone yet but I had a company here in Michigan who I met up with to drop off my phantom and have them install FPV on it. I picked it up Tuesday and he was showing me how the FPV worked and all was well. I wasn't able to fly until yesterday which was my first time with the FPV. I did an advanced IMU calibration on Tuesday when I got it home and that went great. My wife and I went to my dads house yesterday to show him the new system. I calibrated the compass and waited until I got 12 satellites and took off. I went up to 35m and started heading north over his cornfield. I got out to 135m and the FPV was VERY choppy and unusable. I stopped and brought it back to 115m where I got the signal back. I knew something was wrong so I was flying back to land it and all at once it went full bore into my dads woods. I had no control and I even flipped my fail safe switch with no luck. We herd it crash into a tree and my stomach sank. We were about 300 feet away from where it crashed and the sound it made when it hit the tree was just awful and loud. We have searched for 10 hours and cant find it. Our conclusion is that it is stuck in a tree way up where we cant see it. I didnt see where it hit because I had no FPV. I called the company and he is suppose to get back with me tomorrow but I doubt he will help any. Is it possible they caused this? Maybe something wasn't installed correctly? I just find it coincidental that first flight after they work on it and it fly's away. Any suggestions would be great.

    The bad part is im going to my in-laws cabin on the lake Tuesday and now have nothing to fly. I may get a vision +
     
  2. PB30X

    Joined:
    Feb 24, 2014
    Messages:
    50
    Likes Received:
    3
    Location:
    Pennsylvania
    By chance did you check and see if the WiFi was NOT on standby mode before flight? I accidentally let someone disconnect my GoPro from the gimbal only later to put it back on I ALWAYS DO A PREFLIGHT checklist and NOTICED my wifi was blinking blue... Just a thought, other than that seems like compass or calibration is at fault but that would be speculating.. Sorry Bud....
     
  3. Detroit

    Joined:
    May 6, 2013
    Messages:
    118
    Likes Received:
    28
    Location:
    Ann Arbor MI
    Yea wifi wasn't on. I check that as well. Don't know what I should get now...

    Sent from my Galaxy S5 using my neighbors internet