Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Is the horizon level better with Ver. 1.4?????

Discussion in 'Pro/Adv Discussion' started by hidaven, Sep 7, 2015.

  1. hidaven

    Joined:
    Jul 18, 2013
    Messages:
    317
    Likes Received:
    110
    Thoughts??? The motor and gimbal was dancing a lot during the update and seems to be sitting more level on my desk.......Thoughts?
     
  2. SENC

    Joined:
    Jul 12, 2015
    Messages:
    184
    Likes Received:
    58
    Location:
    NC
    I sure hope so! Some said 1.3.2 fixed it for them, but not for me. I have my doubts, though, as I've been running 1.4.000x beta firmwares while testing litchi and have still had the horizon tilt - but maybe it was fixed in the final release.
     
  3. Tony Perry

    Joined:
    Aug 21, 2015
    Messages:
    186
    Likes Received:
    70
    Location:
    San Francisco, CA
    I sure hope so. The problem most definitely was not fixed for me with 1.3.2. I will test and report back this evening.
     
  4. Phantom751874

    Joined:
    Mar 13, 2015
    Messages:
    995
    Likes Received:
    269
    I'm sending my P3P in for off horizon through the last 3 firmware releases. My gimbal wanders around in flight as well. I believe in my case it's a mechanical issue. My P3A has never had the issue.
     
  5. gfredrone

    Joined:
    Jan 24, 2014
    Messages:
    1,221
    Likes Received:
    191
    Horizon seems better on my initial walk through of the house. Will put her in the air this evening and report back.
     
  6. 2nd2non

    Joined:
    Jan 14, 2015
    Messages:
    796
    Likes Received:
    208
    Location:
    Orange County, California
    My horizon was perfect after upgrading, and normal imu/gimbal calibration today. Ran two batts through the different modes and did some manual flying with heavy yaws. My gimbal finally stopped drifting between yaws! I would say the software issue is probably fixed. Some may still have hardware issues.
    Note: this is my first public fw upgrade since 1.26. I've been using the SDK fw for the last couple months. Perhaps a previous public fw fixed the software issue...
     
  7. bKanzi

    Joined:
    Jun 26, 2015
    Messages:
    17
    Likes Received:
    8
    Mine was fine on 1.2.6, went off kilter on 1.3.2, now back rock solid on 1.4.
     
  8. gfredrone

    Joined:
    Jan 24, 2014
    Messages:
    1,221
    Likes Received:
    191
    Same here. Still need to do cold IMU cali but was pretty good on my first POI test tonight.