Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Is my wifi module good??

Discussion in 'Phantom 2 Vision + Help' started by Hvydg, Jul 22, 2015.

  1. Hvydg

    Joined:
    Jul 11, 2015
    Messages:
    28
    Likes Received:
    2
    Hi everyone. Just got a used pv2+. The camera won't power on. (No led) when the bird is powered on and the extender is off I'm picking up a MAC address when I run
    Vistumbler. Does this mean the wifi module is ok? I'm guessing the main gimbal board is bad since the led is not on?Any help is greatly appreciated.
     
  2. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    16
    If your power leads are plugged in at the camera and inside the bird than your gimbal main board is toast. You will need to do some testing, if you have another camera/gimbal available plug it in.

    Jeremy
     
  3. Hvydg

    Joined:
    Jul 11, 2015
    Messages:
    28
    Likes Received:
    2
    Yes. All the cables are plugged up. I guess the wifi module is ok since I'm picking it up. I will not connect to the vision app. It will show a green light when you open the app but when you click on camera if says connection to phantom failed. I assume that's because the gimbal board of toast?
     
  4. Hvydg

    Joined:
    Jul 11, 2015
    Messages:
    28
    Likes Received:
    2
    If the main gimbal board is bad will that cause it not to have telemetry also in the vision app?