Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

iPad not recognized after DBS itelite mod

Discussion in 'Pro/Adv Discussion' started by Brind, Jan 23, 2016.

  1. Brind

    Joined:
    Jan 23, 2016
    Messages:
    6
    Likes Received:
    3
    Hi,

    I just install the itelite DBS mod, but now my iPad seems not be recognized by the RC.
    The ribbon cable seems to be correctly plugged.

    What went wrong?

    Thanks a lot for your help
     
  2. Brind

    Joined:
    Jan 23, 2016
    Messages:
    6
    Likes Received:
    3
    I reopened and check every connections, all seems to be good.
    Is there a way to be sure the USB/HDMI card is properly connected ?

    thanks
     
  3. Brind

    Joined:
    Jan 23, 2016
    Messages:
    6
    Likes Received:
    3
    More infos :
    - RC is correctly bind (green led when the drone is on)
    - I can start motors, everything works
    - I remember that C1 pulled the camera down when pressed. Now it emit a "beep" but the camera doesn't move.

    I think my clamp may damage the ribbon, but i'm not sure. Attached some pics.

    Is there anybody here damaged the ribbon ? where can i find another one ?
    DJI sells the HDMI card, is there a new ribbon in the pack ?
     

    Attached Files:

  4. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,234
    Likes Received:
    915
    Location:
    Indy, USA
    Did you try to loosen the clamp and insert the ribbon further into it, and the re clamp? It looked like it may have slipped out some.
     
  5. Brind

    Joined:
    Jan 23, 2016
    Messages:
    6
    Likes Received:
    3
    Yes, I tried multiple times.
    Previous pics are just to show the ribbon little damages.
    Attached, the the final pic of the RC when a made tests. Ribbon connections are correctly aligned.
     

    Attached Files:

  6. Brind

    Joined:
    Jan 23, 2016
    Messages:
    6
    Likes Received:
    3