Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

iOSD or Immersion RC 5.8 FAIL?

Discussion in 'FPV (First Person View)' started by scooter339, Apr 24, 2014.

  1. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    I'm flying a P2, just installed the immersion, which I tested with the Black Pearl FPV, it worked great.

    Then I installed the iOSD and now I have no video from the GoPro and the telemetry data displays on the Black Pearl but the picture is rolling

    I turned on the camera.
    I checked the integrity of the solder joints.
    The zenmuse is working.

    Any ideas?
     
  2. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    I forgot to mention that the settings of the Black Pearl are: mode - div, Band F, Channel 1
     
  3. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    How do you have the iOSD mini wired up exactly (have a pic)?
     
  4. ashleyg

    Joined:
    Jan 8, 2014
    Messages:
    24
    Likes Received:
    0
    Is the Black Pearl for PAL?, mine came set for PAL had to change to NTSC
     
  5. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
  6. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    I'm not clear about how to verify what setting it's on or how to change it.
     
  7. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    I see video output from your iOSD mini, but no video being fed in to it.

    The video port on the side of the iOSD unit should have two leads coming in from the Phantom mainboard (video in+ground), and two leads going out to the Immersion Tx.

    This cable shows how it should be connected (the loose white plug on the end at the top of the pic is what plugs in to the Phantom's main board): http://www.firstpersonview.com/cables/p ... ransmitter

    Also, if the video from the gopro was displayed on the monitor fine before the iOSD mini was added, then the NTSC setting should be correct.
     
  8. ashleyg

    Joined:
    Jan 8, 2014
    Messages:
    24
    Likes Received:
    0
    Its in the menu....ive had my BP reset to PAL in the past randomly
     
  9. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    Here's a detail of the two leads coming from the iOSD http://screencast.com/t/Qn716DINLD
     
  10. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
    Like stated above. Your iosd is install wrong. It has a video in from the camera and a video out to the immersion. You totally cut off two wires from the iosd harness that needs to be wired. And I should say HAS to be wired. Your video from your camera HAS TO MUST be passed through your iosd.

    The yellow wire in the bottom left corner is your video out from the camera that HAS TO be connected to your iosd video in.

    Flip that iosd around and you will se in gnd out gnd...

    How to I know, I've installed 7 already...
     
  11. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    First, Boozshey - Thanks.

    Second, I believe you're right and I will make the connections tomorrow and post the results.
     
  12. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
    I'm on my iPad but tomorrow can draw a better picture if you can't figure it out. Keep me in the loop.
     
  13. jfischer

    Joined:
    Apr 7, 2014
    Messages:
    10
    Likes Received:
    0
  14. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
    Good find! Can't describe it better.
     
  15. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    That's the video I used, and yes I got it wrong.
     
  16. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
    Can you flip It over and show me where the other yellow wire is going.
     
  17. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
  18. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
  19. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    I can work with this. I'll post the results

    Thanks - you're a pal.
     
  20. scooter339

    Joined:
    Feb 14, 2014
    Messages:
    245
    Likes Received:
    0
    Location:
    Grand Junction, Colorado
    The wiring is correct this time, but the results are the same.

    Here's how my iOSD and Immersion VTX are wired: http://smg.photobucket.com/user/Boozshey/media/phantom/IOSD_zpsa4fba8e2.jpg.html
    All the solder joints are solid and wrapped.

    The Black Pearl is set to DIV Ch. F band 1. I can see the iOSD values, but they roll like an analog TV out of whack.

    The VTX worked before I installed the iOSD.
    The VTX seems hot, the red light is on, and there are other components that are hot too so ... ?
    The Phantom will get a GPS lock but won't fly.

    I rarely use emoticons, but here is where I'm at.

    :evil: :?: :?