Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

iOSD mini problem

Discussion in 'FPV (First Person View)' started by Buk, Aug 20, 2014.

  1. Buk

    Buk

    Joined:
    Feb 28, 2013
    Messages:
    654
    Likes Received:
    29
    Location:
    Iowa, United States
    Every so often the telemetry does not show up on my monitor. It either does not show up at Phantom power up or disappears while in flight. However, the video feed from the GoPro is always there.

    I don't mean just the dynamic information is gone, but both dynamic and the static information from the iOSD does not show up.

    Powering the Phantom down and back up once or twice will return the iOSD information. The LED on the iOSD is always blinking. I've tapped on every connection and nothing seems to be loose. I've plugged and unplugged the external can-bus connection to make sure it's tight. And the fault occurs with different batteries.

    How do I trouble shoot this issue? Or is it a matter of ordering an new iOSD mini?

    Phantom 2, iOSD mini, Immersion 600, Zenmuse H3-2D, Black Pearl

    Thanks,
     
  2. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,376
    Location:
    Live! From New York!
    Thats definitely an issue. How old is it? I had to have mine replaced as it only showed the static data. Is this a new problem that coincided with a Phantom firmware upgrade? If it is a new issue since upgrading check to see that the iOSD is at the latest firmware also.
     
  3. Buk

    Buk

    Joined:
    Feb 28, 2013
    Messages:
    654
    Likes Received:
    29
    Location:
    Iowa, United States
    Thanks for your interest.

    The iOSD is out of warranty, purchased 12/27/2013. The firmware was updated upon installation, as far as I know there has been only one iOSD specific update. You make an excellent point about the problem appearing when a firmware update was performed on the Phantom. I cannot confirm that, but I've done all the updates since 1.08, except the most recent 3.06.

    When time permits, I will update to 3.06 and see if the problem goes away. If not, I guess it's time to replace the iOSD mini. A new iOSD would also help identify if there is a larger concern (impending can-bus or NAZA failure).

    Thanks again,
     
  4. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    6
    Location:
    N 44.895 W 93.354 Minnesota
    Sounds like canbus connection issue. At the connector or internally in IOSD itself. Try cleaning contacts w/Isopropyl alcohol.
     
  5. Buk

    Buk

    Joined:
    Feb 28, 2013
    Messages:
    654
    Likes Received:
    29
    Location:
    Iowa, United States
    Thanks, I have tried unplugging and plugging the iOSD connector into the can-bus connector on the leg of the Phantom 2, but have not tried alcohol or contact cleaner.

    Will give that a try. Does seem odd, without touching iOSD or it's connections, powering down and then power up Phantom battery brings telemetry information back. Like that wakes something up that is sleeping. Wake and sleep technical terms in electronics (ha ha).

    I have NOT tried unplugging and plugging the video in/out connector to the iOSD as the pass-through connection of the GoPro seems very solid (I never lose GoPro video) and messing with a good connection of those mini/micro cable connections seems to invite problems.