Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

IOSD Mini - 0V Battery

Discussion in 'Phantom 2 Discussion' started by fixedwing, Oct 3, 2014.

  1. fixedwing

    Joined:
    Aug 4, 2014
    Messages:
    24
    Likes Received:
    0
    I am not sure if this is the same battery issue others are having, hence the new thread. I searched for IOSD 0v and had no success in finding others.

    I was out flying tonight when I experienced a brief drop from my Phantom 2 (shake in fpv and height reduced ~10M). The battery read out on the IOSD mini display then said 0V and 0% battery, I could also see my red status lights started to flash green and yellow. If it wasnt for the drop I would have suspected just a fault with the IOSD mini.

    I quickly brought the machine back, and after about 30 seconds of flight, just as I was about to land the voltage readout returned. It was now saying 20%, even though I was over 40% less than a minute ago when the issue happened. The battery has been discharged 9 times, and is at 97% of life. The 3 calls are within 3mV of each other.

    This is the first issue I have had with my Phantom 2 that is not pilot error. Quite a serious issue when I do a lot of low altitude flight over water. A 10M drop would have destroyed my phantom + gopro etc on most of my flights. FYI the serial number of the battery is 32523.

    Kit:
    Phantom 2 - Approx 50 flights
    H3-3D
    GoPro 3
    ImmersionRC 600mw transmitted
    IOSD Mini
     
  2. noiseboy72

    Joined:
    Jul 13, 2014
    Messages:
    575
    Likes Received:
    17
    Location:
    Lincs, UK
    Sounds like a dodgy or dirty contact. Worth checking the battery spade connectors are clean and that the battery is always fully inserted. It is easy to not fully locate it, causing arcing and high resistance connections, which limit current flow and hence, power level.
     
  3. fixedwing

    Joined:
    Aug 4, 2014
    Messages:
    24
    Likes Received:
    0
    The batteries are so new that the connections are still clean. I performed a full discharge / recharge cycle and flew again yesterday without issue. I have added "check battery fully inserted" to by pre-flight checks as that is all I can think of.