Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

IOC Home Lock not working on FC40

Discussion in 'General Discussion' started by npalen, Mar 19, 2014.

  1. npalen

    Joined:
    Mar 12, 2014
    Messages:
    532
    Likes Received:
    8
    Location:
    Kansas
    I'm having trouble with Home Lock not working in GPS mode and would like to hear some things I might check. I'm getting the green only flashing light indicating adequate number of satellites after going thru the startup sequence with the Phantom.

    I have the left switch in Home Lock and the right switch in GPS at takeoff but get no home lock even after flying outside of the 10m "circle". There is a statement in the manual that Home Lock shouldn't be engaged until after flying outside the 10m circle but that method doesn't seem to work either. The craft does hover and respond well when releasing the sticks and flies well as it would with Home Lock switch off.
    Can you guys help me on this?

    Edit: Should mention that I am doing a successful compass calibration also.
     
  2. Jermz

    Joined:
    Mar 8, 2014
    Messages:
    193
    Likes Received:
    3
    We'll start with the basic solution first. The fc40 ships with IOC disabled. You'll need to hook it to a computer and use the naza assistant to enable IOC. You may also want to change the lower position on the other switch to manual from fail safe, since fail safe can be done by switching the controller off.

    If you've already enabled IOC, then I'll let someone else answer, as I've had no issues with it.


    Sent from my iPhone using Tapatalk
     
  3. npalen

    Joined:
    Mar 12, 2014
    Messages:
    532
    Likes Received:
    8
    Location:
    Kansas
    Yes, the IOC has been enabled in Assistant and changed the lower setting to failsafe.
     
  4. Jermz

    Joined:
    Mar 8, 2014
    Messages:
    193
    Likes Received:
    3
    Well then, I got nothing for you. It's worked well for me, usually it heads to a point 10 or so feet to the side of me.


    Sent from my iPhone using Tapatalk
     
  5. ericdes

    Joined:
    Feb 12, 2014
    Messages:
    282
    Likes Received:
    0
    The lower setting to failsafe? That is the right switch activation, you need to enable the left switch for home lock and course lock.

    Double check.
     
  6. npalen

    Joined:
    Mar 12, 2014
    Messages:
    532
    Likes Received:
    8
    Location:
    Kansas
    Yes, lower setting on the right switch to FAILSAFE. Uppermost is GPS and middle is ATTI
     
  7. npalen

    Joined:
    Mar 12, 2014
    Messages:
    532
    Likes Received:
    8
    Location:
    Kansas
    Apparently the problem was that I had the switch in the Home Lock position when initially lifting off. Waiting until the craft is outside the 10M circle then switching to Home Lock works fine.
    Problem solved!